Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: There was no AutoMate Task Service responding at 'localhost'
Topic Summary:
Created On: 03/27/2018 12:28 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/27/2018 12:28 PM
User is offline View Users Profile Print this message

Author Icon
KevinLawrence
n00b (>6 posts)

Posts: 3
Joined: 02/01/2018

Whenever I try to open AM11 task administrator I get a message "There was no AutoMate Task Service responding at 'localhost'" I've tried restarting the server, restarting the service, uninstalling/reinstalling AM11. I tried the things in the below topic but they don't seem to work. I think it may be related to the service user issue but there doesn't seem to be a "TaskService" folder within regedit to check the settings for AM11, only 10. Does anyone know how to troubleshoot this issue?

Related post
 03/27/2018 01:50 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello,

Would it be possible to set-up a GoToAssist session where we can take a closer look at this issue? If this is possible please send an email over to AutoMate.Support@helpsystems.com with a list of your availability.

Note: Please reference this forum thread in your email.

-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 04/21/2018 12:19 PM
User is offline View Users Profile Print this message

Author Icon
ScottLies
n00b (>6 posts)

Posts: 4
Joined: 08/15/2016

Having a similar issue. It started after I updated the Service User.

Any update?
 04/21/2018 01:48 PM
User is offline View Users Profile Print this message

Author Icon
ScottLies
n00b (>6 posts)

Posts: 4
Joined: 08/15/2016

Ok follow up on Automate 11.

I was able to uninstall and had to fully delete the C:\ProgramData\Automate\Automate 11 folder before it would allow me to do a clean install.

Any account change I make to the service user is causing it to not connect after the service restarts. Giving the above error "There was no AutoMate Task Service responding at 'localhost'"

I need this updated as our automate heavily utilizes shares and triggering from them.

Full set of events.

Our server has a running Automate 10 instance
I did a backup of the Automate 10.
I installed Automate 11 side by side
I restored Automate 10 Backup to Automate 11.
Tested jobs ( ran successfully )
Tested restarting the service ( Successful )
Tested restarting the server ( Successful )
Changed the Service User
Restarted the Service ( Fail: Can no longer connect )
Restarted the Server ( Fail: Can no longer connect )
Uninstall Automate 11 and Delete Program Data.
ReInstall Automate 11 ( I can connect again. )

I tried a couple different accounts with this process. All did the same.
 04/22/2018 10:25 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Scott,

Why are you updating the service user? The Automate service should be running as local system and the service user settings in Task Administrator should be blank. The service in Task Administrator is for a very specific scenario where the Automate settings and tasks are located remotely as opposed to locally.

-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 04/23/2018 07:48 AM
User is offline View Users Profile Print this message

Author Icon
ScottLies
n00b (>6 posts)

Posts: 4
Joined: 08/15/2016

Ok.

There was items I was reading somewhere that seemed to indicate it was necessary for UNC Share triggering. This was how we had it setup in the Automate 10 and Automate 9 installations prior.
 04/23/2018 07:58 AM
User is offline View Users Profile Print this message

Author Icon
ScottLies
n00b (>6 posts)

Posts: 4
Joined: 08/15/2016

Guessing it is more then that. When I stop/restart after loading from 10 It will not connect to the local host.
 04/24/2018 09:08 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Scott,

Would it be possible to set-up a GoToAssist session where we can take a closer look at this issue? If this is possible please send an email over to AutoMate.Support@helpsystems.com with a list of your availability.

Note: Please reference this forum thread in your email.

-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 05/09/2018 07:11 AM
User is offline View Users Profile Print this message

Author Icon
KevinLawrence
n00b (>6 posts)

Posts: 3
Joined: 02/01/2018

If you migrated from 10 to 11 via backup and restore it may have carried over incorrect Task Service port information. You need to make sure it's correct in the settings after restoring and before the task service has been started again. If it's already locked up you need to edit the port information in the Task Service Config xml file located in C:\ProgramData\AutoMate\AutoMate 11.
 05/09/2018 04:45 PM
User is offline View Users Profile Print this message

Author Icon
JasonRiley
Apprentice (20-49)

Posts: 25
Joined: 11/02/2016

FYI, further to Kevin's comment above and in case you don't have them, the correct port settings for AM11 in the config file are:

<ServerTCPPort _tmplitem="7" >11010</ServerTCPPort>
<ServerHTTPPort _tmplitem="7" >11011</ServerHTTPPort>
 06/12/2018 11:16 AM
User is offline View Users Profile Print this message

Author Icon
PaulMills
Student (5-19 posts)

Posts: 8
Joined: 02/21/2010

I have just migrated from AM10 to AM11 and having restarted my server (2012R2) I now have the same issue. I also did a full backup and restore - there was no warning to say I should only restore the scripts.....
I have checked that the server ports are correct as above.
Using netstat -an it certainly doesn't look like the server is listening
There are no entries in the logs
I also use the service account to access remote shares as part of my scripts and have also done this in AM10/9/8- if there is another way to do this it would be helpful to know.....
Meanwhile the only thing I can think of is to wipe AM11 and start again which I am not very happy about.....
 06/12/2018 11:30 AM
User is offline View Users Profile Print this message

Author Icon
PaulMills
Student (5-19 posts)

Posts: 8
Joined: 02/21/2010

.... interesting, so I edited the Task Service Config XML and deleted the password for the service user and restarted the AM11 service.
Now suddenly the AM icon appears on the task bar, tasks are trying to run and running netstat the server is listening on the correct ports (I think) 0.0.0.0:10011 and 0.0.0.0:11010.
The only problem is that the task administrator still wont connect and now my network shares in my scripts wont work
 06/12/2018 11:34 AM
User is offline View Users Profile Print this message

Author Icon
Justin Aucoin
HelpSystems

Posts: 360
Joined: 02/15/2016

Hi Paul,

From you message it does appear that the HTTPPort is still set to the Automate 10 one. To correct please follow the steps below.

1) Stop the Automate 11 service.
2) Edit the C:\ProgramData\AutoMate\AutoMate 11\TaskService.config.xml.
3) Next search for <ServerTCPPort> and verify that it is set to 11010, if not update it.
4) Then search for <ServerHTTPPort> and verify that it is set to 11011, if not update it.
5) Once these changes have been made, save the updated file and restart the Automate 11 service.

-------------------------

Justin Aucoin | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 06/12/2018 11:49 AM
User is offline View Users Profile Print this message

Author Icon
PaulMills
Student (5-19 posts)

Posts: 8
Joined: 02/21/2010

Hi Justin,
Many thanks for your response, you are absolutely correct, it has been a long day and I wasn't reading my 1's and 0's correctly.
HTTPPort was 10011 not 11011 - corrected and I was able to connect to task manager.
I then re-entered by service user credentials and rebooted the server - now AM11 is not listening again (the ports are correct now).
If I cant use the service account to connect to network shares in my script how is the correct way to do this?
Any assistance would be appreciated
 06/12/2018 11:52 AM
User is offline View Users Profile Print this message

Author Icon
Justin Aucoin
HelpSystems

Posts: 360
Joined: 02/15/2016

Hi Paul,

The Service user is intended to be used only if you wish to keep your task's aml files in an external location. For file system monitoring, you want to set the user credentials in the file system triggers themselves under the Users section. Like the task logon settings, you can specify a user, or set it to use the default user. In either case, it is recommended to set the user to the same credentials as the task itself.

-------------------------

Justin Aucoin | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 06/12/2018 12:23 PM
User is offline View Users Profile Print this message

Author Icon
PaulMills
Student (5-19 posts)

Posts: 8
Joined: 02/21/2010

Many thanks for your advice, I will follow and see where that leads me.
Many thanks again for your support
 06/12/2018 12:42 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello Paul,

We look forward to hear from you.

-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1168 guests browsing this forum, which makes a total of 1168 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog