Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Numeric constants compared to numeric dataset values evaluate as false
Topic Summary:
Created On: 05/08/2018 05:36 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/08/2018 05:36 PM
User is offline View Users Profile Print this message

Author Icon
JasonRiley
Apprentice (20-49)

Posts: 25
Joined: 11/02/2016

If I have a constant named courseIdCorporateTraining with a value of 197, then compare this using IIF against a dataset record of the same value (197) it evaluates to False. In previous versions of AutoMate, numeric constants evaluated against numeric dataset records evaluated to True. In AM11, a numeric constant with only evaluate as true when compared against a dataset record if the dataset record is text.

The attached sample code assumes a constant named courseIdCorporateTraining with a value of 197 has been defined. The IIF statement will evaluate as true only if the dataset record is converted to text, e.g. Select '197' instead of Select 197, or Select Cast(197 as Char). This is a bit of a concern for me, as I am likely to have significant number of comparisons of dataset values against constants, many of them numeric.

Is this change in AM11 intentional or a bug?


Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)
 05/14/2018 10:08 AM
User is offline View Users Profile Print this message

Author Icon
Devin Cannon
HelpSystems

Posts: 398
Joined: 03/17/2016

Hi Jason,

I'm seeing the same behavior here. I don't believe this change was intentional, but I'm looking into it and will let you know.

-------------------------

Devin Cannon | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 05/15/2018 03:23 PM
User is offline View Users Profile Print this message

Author Icon
Devin Cannon
HelpSystems

Posts: 398
Joined: 03/17/2016

Hi Jason,

This issue has been assigned a bug number 24198. We hope to correct this issue in an upcoming release of the software.

Please let us know if you have any questions or concerns.

-------------------------

Devin Cannon | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 660 guests browsing this forum, which makes a total of 660 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog