Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: v9 to v11 any luck
Topic Summary:
Created On: 05/09/2018 05:33 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/09/2018 05:33 PM
User is offline View Users Profile Print this message

Author Icon
N i c k
Expert (100-199)

Posts: 183
Joined: 03/11/2006

Has anyone had any success moving from v9 to v11 using the backup/import functions?

Every attempt fails. Even using the delivered v9 backup and import into v11 fails.
 05/09/2018 06:56 PM
User is offline View Users Profile Print this message

Author Icon
JasonRiley
Apprentice (20-49)

Posts: 25
Joined: 11/02/2016

Hi Nick,

I did a restore (including constants, etc) from 9.0.5.4 to 11.0.2.22 (since upgraded to 11.0.5.8) to recover some archived tasks we hadn't been using for a while without any issues. The restore from AM9 to AM11 took several minutes to process and it's important to wait until the dialogue box at the bottom of the page indicates the restore has completely finished. On the negative side, many of the triggers were corrupted and I believe that relates to tasks where we had a holiday exclusion defined. There's also a current bug which inhibits applying a Holiday exclusion on a scheduled task when using an hour, minute or seconds interval. Aside from that, the restore was fine. I know a lot of people export tasks and import them manually, but with the volume of tasks we have that's just too much work.
 05/09/2018 09:25 PM
User is offline View Users Profile Print this message

Author Icon
N i c k
Expert (100-199)

Posts: 183
Joined: 03/11/2006

Hi Jason, Very interesting. What Windows OS did you have success on?


I've have attempted this with Automate Version 9.0.5.4 to 11.0.5.8 and failed every time.

Attempted on:
Windows Server 2008 R2
Windows Server 2012 R2
Windows Server 2016

Here is the AMTA display.
5/9/2018 12:39:18 AM,localhost,Connecting ...
5/9/2018 12:39:18 AM,localhost,Connected to 'localhost'.
5/9/2018 12:41:03 AM,localhost,Restoring tasks and task database from Automate 9 backup...
5/9/2018 12:41:05 AM,localhost,Switching over to new task database...
5/9/2018 12:41:05 AM,localhost,Upgrading task files to latest AutoMate task file format...
5/9/2018 12:41:05 AM,localhost,Conversion of tasks failed: ImportUtil could not be found or started
5/9/2018 12:41:05 AM,localhost,Configuring triggers...
5/9/2018 12:41:06 AM,localhost,Restore complete. Triggers have been disabled as a precaution. Re-enable triggers by clicking the yellow banner on the Task Administrator after clicking Done.
 05/10/2018 11:13 AM
User is offline View Users Profile Print this message

Author Icon
N i c k
Expert (100-199)

Posts: 183
Joined: 03/11/2006

Also v9 and v11 32 bit
 05/10/2018 01:51 PM
User is offline View Users Profile Print this message

Author Icon
N i c k
Expert (100-199)

Posts: 183
Joined: 03/11/2006

I found a work around to backup v9 and import into v11.

1) Open v9 AMTA delete the samples folder (these are delivered tasks that ship with v9)
2) In v9 create backup file
3) In v11 import the v9 backup file
 05/10/2018 06:15 PM
User is offline View Users Profile Print this message

Author Icon
JasonRiley
Apprentice (20-49)

Posts: 25
Joined: 11/02/2016

Good news FYI, we are running on Windows 10 64-bit. Your approach sound step same as ours, with the exception of the sample files which we had already removed previously.
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 680 guests browsing this forum, which makes a total of 680 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog