Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: unhandled errors in functions
Topic Summary: unhandled errors in functions cause the task to hang up
Created On: 05/22/2018 03:23 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/22/2018 03:23 PM
User is offline View Users Profile Print this message

Author Icon
JivaJentile
Journeyman (50-99)

Posts: 94
Joined: 03/07/2006

I am just beginning to look at refactoring some code into the new functions model. I came upon this...
unhandled errors in functions cause the task to hang up.

I rely on the Task Failure event to do my error handling, but apparently it never gets run in this case. I also rely on the systems global error settings to send me an email whenever an unhandled error occurs. this obviously didn't get done either; the task was just hung. it had to be manually stopped in the SMC.

I ran some tests and confirmed the behavior... does anyone have any experience with this? thanks....
[hi jean hope your still out there...]
 05/25/2018 07:38 AM
User is offline View Users Profile Print this message

Author Icon
Alex Escalante
HelpSystems

Posts: 871
Joined: 02/26/2014

Hello Jiva,

What step/action is the task getting hung up on?

A quick workaround would be to set a timeout so that the task errors after hanging for a certain amount of time.

However it is best to address why it is getting hung up to eliminate the issue all together.

-------------------------

Alex Escalante | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 990 guests browsing this forum, which makes a total of 990 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog