Network Automation Software
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: PGP email
Topic Summary: PGP Email
Created On: 06/14/2018 12:54 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/14/2018 12:54 PM
User is offline View Users Profile Print this message

Author Icon
MartySpeare
Apprentice (20-49)

Posts: 33
Joined: 02/23/2018

Hello

I am trying to send an email that must go through pgp encryption.
Is there a special way this is to be done.

I put [pgp] in the subject line and the task step fails.
 06/14/2018 03:32 PM
User is offline View Users Profile Print this message

Author Icon
Hamid Noorbakhsh
HelpSystems

Posts: 454
Joined: 07/29/2008

Hi Marty,
You should be able to just encrypt your content and add as email Body and you are set. To encrypt, you need the recipient's public key and a set of keyrings for yourself also (public and private). You will need to import their public key into your public keyring and then use it to encrypt the message (or attachment) and then send it to them. You can use the steps below as a template. You will have to fill in the paths for files and enter correct email addresses of course. For more information please see http://users.ece.cmu.edu/~adrian/630-f04/PGP-intro.html

I have tested this code and it works with PGP, so good luck.


Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)


-------------------------
Thank you for choosing AutoMate

Hamid Noorbakhsh | Senior Software Engineer
AutoMate | A Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700

Edited: 06/14/2018 at 03:42 PM by Hamid Noorbakhsh
 06/15/2018 12:03 PM
User is offline View Users Profile Print this message

Author Icon
MartySpeare
Apprentice (20-49)

Posts: 33
Joined: 02/23/2018

Thank You!! It is working!
Statistics
18257 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 6686 on 11/01/2020 at 01:24 AM.
There are currently 1600 guests browsing this forum, which makes a total of 1600 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2021 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog