Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Unreliable File System Triggers
Topic Summary:
Created On: 07/13/2018 08:11 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/13/2018 08:11 AM
User is offline View Users Profile Print this message

Author Icon
DaveWest
Student (5-19 posts)

Posts: 14
Joined: 12/22/2017

We have file system triggers set on approx 75 folders - most of the time they trigger just fine....but a couple times a week *randomly* they'll just stop firing. A quick service restart resolves the issue, but is there something else we can do to more permanently fix this issue?

We are running AM Pro 11.0.2.22 on Win 2012 R2 64-bit. All triggers are configured to use a local folder (E:\dir\subdir\subdir) and none have filters. We have a default user (specified in Options -> Default Properties) that has sufficient access to the local drive and UNC paths used in the tasks. Tasks are set to run as default user in all states (logged on, logged off, locked). The file system triggers are configured with the "No user required" setting.

Suggestions?
 07/17/2018 03:54 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Dave,

Have you noticed any errors in the Windows Event Viewer (under application) when triggering stops?

How much memory is allocated to this machine?

-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 07/19/2018 11:25 AM
User is offline View Users Profile Print this message

Author Icon
DaveWest
Student (5-19 posts)

Posts: 14
Joined: 12/22/2017

Nothing stands out in the event viewer. Automate is running on a VMWare virtual machine with 4Gb memory.
 07/19/2018 12:12 PM
User is offline View Users Profile Print this message

Author Icon
Hamid Noorbakhsh
HelpSystems

Posts: 454
Joined: 07/29/2008

Dave,
There is a similar issue #23842 in our system that I have fixed for next release. It will greatly increase reliability, however there is no guarantee if there are way too many files added/removed at the same time.
We use Windows built-in technology so the trigger is using Microsoft technology. I have also added in an Event Log entry so this is reported to user as a warning. Hopefully this will satisfy normal to heavy usage better. As ways to remedy this in current release, their best practices suggest using base directories and shorter directory names since the message is sent through a buffer and longer names fill it quicker. The buffer limit is controlled by them, but I moved us from default so messages are not truncated as easily. They also suggest removing sub-directories and having separate triggers for those.

I hope this will increase the reliability.

-------------------------
Thank you for choosing AutoMate

Hamid Noorbakhsh | Senior Software Engineer
AutoMate | A Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 07/20/2018 10:02 AM
User is offline View Users Profile Print this message

Author Icon
DaveWest
Student (5-19 posts)

Posts: 14
Joined: 12/22/2017

Thank you Hamid. Can you please clarify what release version contains the fix or point me to the documentation that shows this info?
 07/23/2018 11:50 AM
User is offline View Users Profile Print this message

Author Icon
DaveWest
Student (5-19 posts)

Posts: 14
Joined: 12/22/2017

*bump*
 07/23/2018 11:57 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Dave,

We are aiming for v11.1.0 which is slated to be released within the next 30 days.

-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 726 guests browsing this forum, which makes a total of 726 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog