Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Task to log off gets unknown status
Topic Summary:
Created On: 10/02/2017 04:56 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/02/2017 04:56 PM
User is offline View Users Profile Print this message

Author Icon
KathyMcdonald
Journeyman (50-99)

Posts: 65
Joined: 09/21/2015

I have a workflow that has a logon task, a simple interactive task, then a log off task.  After the interactive task, the log off task runs but displays a Message 'Task 'Logoff' has reported an unknown status'.  Then the workflow does not exit... it is still listed as Running in the EXECUTION STATUS.  The server was logged off OK though.  The LOGON properties for the task are using the specified Default user. 

When I run it with LOGON properties using background user, it doesn't log off but the workflow does complete.

I have attached the workflow...

 

 



Edited: 10/05/2017 at 12:14 PM by KathyMcdonald
 10/03/2017 12:51 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello,

Are you able to watch the logon sequence outside of RDP?

-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 10/03/2017 01:40 PM
User is offline View Users Profile Print this message

Author Icon
KathyMcdonald
Journeyman (50-99)

Posts: 65
Joined: 09/21/2015

Yes, logon works fine with the workaround provided by support.  Now the logoff is having issues.

 10/04/2017 09:55 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello Kathy,

Can you make sure that the "Run with highest privileges" option is checked? This option could be found in the Logon option of the workflow or default properties.

-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 10/05/2017 12:15 PM
User is offline View Users Profile Print this message

Author Icon
KathyMcdonald
Journeyman (50-99)

Posts: 65
Joined: 09/21/2015

Running with Highest Privileges didn't make a difference.  I applied that option to the workflow and inherited by the task, and also to the task separately when run as background user.

 

 10/05/2017 01:17 PM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Kathy,

A logoff step running within a background task will not log off the workstation. When the workflow/task unlocks that machine, do you see the agent icon in the system tray?




-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 10/05/2017 01:37 PM
User is offline View Users Profile Print this message

Author Icon
KathyMcdonald
Journeyman (50-99)

Posts: 65
Joined: 09/21/2015

Yeah, it was a shot in the dark.  I had tried it already with the other logon options.

 10/09/2017 09:52 AM
User is offline View Users Profile Print this message

Author Icon
Justin Aucoin
HelpSystems

Posts: 360
Joined: 02/15/2016

Hi Kathy,

Would it be possible to set-up a remote support session where we can take a closer look at this issue? If this is possible please send an email over to AutoMate.Support@helpsystems.com with a list of your availability. Also please verify the Operating System of the machine in question and it's bit level, as well as the version and bit level of the AutoMate software.
Note: Please reference this forum thread in your email.

-------------------------

Justin Aucoin | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 11/10/2017 02:44 PM
User is offline View Users Profile Print this message

Author Icon
KathyMcdonald
Journeyman (50-99)

Posts: 65
Joined: 09/21/2015

I tried creating a NoOp task that does nothing but has logon properties of background user.  The Logoff task success and fail path goes to that task but the workflow still doesn't exit.  It is listed in the Execution Status as running with no tasks underneath it.  The NoOp task never gets executed.

 



Edited: 11/16/2017 at 09:52 AM by KathyMcdonald
 04/24/2018 01:17 PM
User is offline View Users Profile Print this message

Author Icon
KathyMcdonald
Journeyman (50-99)

Posts: 65
Joined: 09/21/2015

Is there any update on this issue? I am still having workflows left hanging after logging off
 04/27/2018 07:25 AM
User is offline View Users Profile Print this message

Author Icon
Alex Escalante
HelpSystems

Posts: 871
Joined: 02/26/2014

Hi Kathy,

Would it be possible to set-up a remote support session where we can take a closer look at this issue? If this is possible please send an email over to AutoMate.Support@helpsystems.com with a list of your availability. Also please verify the Operating System of the machine in question and it's bit level, as well as the version and bit level of the AutoMate software.
Note: Please reference this forum thread in your email.

-------------------------

Alex Escalante | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 04/28/2018 10:37 AM
User is offline View Users Profile Print this message

Author Icon
KathyMcdonald
Journeyman (50-99)

Posts: 65
Joined: 09/21/2015

OK, sent availability to Automate.Support. Thanks
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 524 guests browsing this forum, which makes a total of 524 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog