Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: OLEDB vs ODBC for connection to AutoMate's data store
Topic Summary: implications for Failover/HA use with MS Availability Groups
Created On: 11/04/2017 12:06 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/04/2017 12:06 PM
User is offline View Users Profile Print this message

Author Icon
JohnScott
Artisan (200-499)

Posts: 231
Joined: 10/27/2010

Recently we've been trying to move our mission-critical DBs to MS SQL Availability Groups for high availability and disaster recovery. We have found that Microsoft supports some aspects of connection to availability groups only in ODBC and not in OLEDB. The critical option for us is MultiSubnetFailover, since our secondary server is offsite in our DR data center.

The connection string editors for the Open SQL/SQL Query actions allow one to choose which Provider to use to connect to the SQL server, and thus provide a potential way to choose a driver. However, in the SMC Options > Server > Server Settings > Data Store configuration to connect to a SQL db for AutoMate's central data store, there are no options to choose a provider or driver to use. For the data store, AutoMate is locked into using some default OLEDB provider.

Because of the way AutoMate's Failover capability relies on a highly available database server, I would have expected you to support Availability Groups and the MultiSubnetFailover option. Are there any plans to provide some way to support connecting to Availability Groups using the MultiSubnetFailover option for AutoMate's core data store?

MS docs page re what drivers MultiSubnetFailover is supported in
MS blog post re 50% connection success rate without MultiSubnetFailover support
 11/09/2017 10:42 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello,

I apologize for the delayed response, we have gone ahead and added a feature request on your behalf 23473.

Thank you for your input.

-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 11/16/2017 04:42 PM
User is offline View Users Profile Print this message

Author Icon
JohnScott
Artisan (200-499)

Posts: 231
Joined: 10/27/2010

If it's not being too pushy, Ricardo, can I ask what you recorded as this request in #23473? I can imagine a couple different ways you might have summarized my request in your write-up. I'd hate for you to do a bunch of work and then deliver something that didn't really meet my needs.

John
 11/17/2017 08:35 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello John,

I won't be able to share that information with you but if you would like to summarize it in your own words, I will be more than happy to add that to the request.

-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 11/17/2017 03:57 PM
User is offline View Users Profile Print this message

Author Icon
JohnScott
Artisan (200-499)

Posts: 231
Joined: 10/27/2010

I would write the feature request as:

In AutoMate Enterprise's connection to its data store, please support Microsoft's MultiSubnetFailover parameter for data stores sourced from MS SQL Always On Availability Groups.

Thank you,
John
 11/20/2017 12:52 PM
User is offline View Users Profile Print this message

Author Icon
Mary Manzano
HelpSystems

Posts: 280
Joined: 03/10/2014

Hi John,

We will submit the request and update you shortly with the enhancement number



-------------------------
Mary Manzano | Technical Consultant
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1851 guests browsing this forum, which makes a total of 1851 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog