Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Error email notifications don't include workflow
Topic Summary: Same task is used in many workflows, if it fails, which workflow was it running for?
Created On: 03/07/2018 11:58 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/07/2018 11:58 AM
User is offline View Users Profile Print this message

Author Icon
KathyMcdonald
Journeyman (50-99)

Posts: 65
Joined: 09/21/2015

Since upgrading to v11.02, we have been getting random errors about a portion of the file is locked. If this error occurs in a task that we use in several workflows, it is difficult to determine which workflow is failed.

Is there any way to include the workflow into the email notification?
---------------------------------
This report is to inform you that an AutoMate Task step has failed to execute properly:

Task name: Get SOP Reference
Step number: 5
Time of error: 3/7/2018 9:08:54 AM
Error message: The process cannot access the file because another process has locked a portion of the file.

Computer name: WDC1BPACORE01
 03/08/2018 05:06 AM
User is offline View Users Profile Print this message

Author Icon
DavidSeibel
Apprentice (20-49)

Posts: 42
Joined: 11/14/2014

I put in a feature request (21124) for this quite a while back. To work around this, I created a failure handling task that I've embedded in every workflow. Every task in our workflows has a failure link to the failure handling task, and I've turned off the step failure emails for all tasks except that failure handling task.

This task then queries the database for any failures that occurred for the current transaction, and reports all of them in an email.

I responded to a similar post on this a while back, and embedded the AML there:
http://forums.networkautomatio...id=14454&enterthread=y
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 690 guests browsing this forum, which makes a total of 690 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog