Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: How long has the current workflow been running
Topic Summary: How long has the current workflow been running
Created On: 05/14/2018 10:22 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/14/2018 10:22 AM
User is offline View Users Profile Print this message

Author Icon
ShannonFields
n00b (>6 posts)

Posts: 3
Joined: 12/05/2008

I am in the process of installed Automate Enterprise V11. One of the checks that we put in our old scheduling software was a check on currently running jobs. If the jobs ran longer than the average minutes + 10%, an email was sent out to notify that a possible issue is happening. I see the AMCurrentWorkflow dataset object but it does not have a start time or currently run time. Any suggestions?
Shannon Fields
 05/16/2018 01:04 PM
User is offline View Users Profile Print this message

Author Icon
DavidSeibel
Apprentice (20-49)

Posts: 42
Joined: 11/14/2014

It's possible to use the API to query for deviations. You can use PoshBPA to query the API easily:

Connect-BPAServer myserver -Port 9708
Invoke-BPARestMethod -Resource "metrics/deviations/list?deviation_percentage=10&deviation_direction=ABOVE"

(9708 is the default port for the API in v11, you may need to change this if you're using a different port.)

It's not something that would run as part of the workflows you want to monitor. You would need to set it up as a separate workflow that monitors for any deviations. You could customize the API call to only return deviations during a certain time frame, or for a certain folder. Here's the API documentation on how to use the call: http://cloud.networkautomation..._RESTful_API.html#185

Since you're using v11, you could also use the built in HTTP GET and JSON Decode actions to accomplish the same thing, without needing to use PowerShell and PoshBPA.
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 236 guests browsing this forum, which makes a total of 236 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog