Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Can't use shared dataset in workflow evaluation
Topic Summary:
Created On: 06/12/2018 11:04 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/12/2018 11:04 AM
User is offline View Users Profile Print this message

Author Icon
JoshPhillips
n00b (>6 posts)

Posts: 1
Joined: 11/11/2016

I'm still new to Automate Enterprise 11, coming from Automate Pro 10. So the workflow system is still a bit new to me, and I admit I could be goofing something up.

I'm trying to implement the sample workflow from here: http://www.networkautomation.c...orkflow/57bb66539904a/ . The goal is to loop through a dataset of files using a counter.

The evaluation is "dsFile.TotalRows <= varCounter". But when it runs, I get this output:

    Workflow 'My Workflow Name' failed because: (10094) ActiveX Automation: Object var is 'Nothing'

The problem seems to be in trying to access the shared dataset from outside a task. Should that normally be possible here? Admittedly, that downloaded sample was designed for BPA 10, so for all I know something changed in AE 11.

Meanwhile I'm using a workaround: in the task that populates the dataset with files, I also populate a shared variable with the "TotalRows" of that dataset. So at least I get a working evaluation.
 06/15/2018 09:53 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello Josh,

Would it be possible to post the workflow for review? If you do not feel comfortable posting it, you can email it over to Automate.Support@helpsystems.com for further review.

Note: Make sure to include the forum thread in your email.

-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 412 guests browsing this forum, which makes a total of 412 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog