Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Email Trigger Not Working
Topic Summary: How to build workflow with email trigger
Created On: 08/10/2018 10:00 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/10/2018 10:00 AM
User is offline View Users Profile Print this message

Author Icon
PatrickMarshall
Student (5-19 posts)

Posts: 13
Joined: 06/14/2016

I have an Email condition defined to look for a specific subject in an email box. If found, it should launch the task.

I can't get this to run without manually initiating. I have tried setting the execution location to Triggered Agent, Condition Agent, and to our Production cluster. The behavior is set to Wait for condition and to Trigger on startup if condition is true. When I launch it manually it is launching the task whether the condition is met or not.

The documentation for the email trigger doesn't match the actual form. It speaks of "Trigger element", "Wait element" and "Conditional element", but there is no where to provide this information.

How do you define the email trigger to wait for an email to arrive that matches the criteria, launch the workflow (task), then reset itself to watch for any more that match?

Attached is my sanitized workflow (accounts, passwords, domains, servers are scrubbed).

I appreciate any help I can get.

Thanks!




-------------------------
Automate 11 BPA Standard
Windows Server 2016
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 962 guests browsing this forum, which makes a total of 962 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog