Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Steps work when logged in and not when scheduled to run
Topic Summary:
Created On: 06/22/2012 09:03 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/22/2012 09:03 AM
User is offline View Users Profile Print this message

Author Icon
NixonJames
n00b (>6 posts)

Posts: 2
Joined: 06/22/2012

Server: Windows Server 2003 SP2, Enterprise Edition

Automate: BPA Server 7.1.3.0

I created a workflow recently to replicate steps that a person would manually do. Basically it opens up to a website using Internet Explorer, logs in, follows a bunch of steps (clicks a few links, buttons) and then finally exports a PDF file and save it to the drive.

If I open up this task and run it manually then it works fine (I can see all the steps it does properly). It doesn't work if I schedule to run it at a certain time - it fails with the following message "Control not found. " at step 10.

I would appreciate If anyone can point me in the right direction. Thanks.

 

P.S. I have overridden  default logon options with the following:

When workstation is logged on: "Specified user (defined below)"

When workstation is logged off: "Run as background user (defined below)"

When workstation is locked: "Run as background user (defined below)"



 Category Survey


steps.aml
steps.aml  (3 KB)

 06/22/2012 09:20 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Hi Nixon,

Interactive actions/tasks/workflows cannot be executed in the background. Because they have to interactive with applications, the workstation needs to be in a logged on session. This is why it works in Task Builder and not when scheduled. When the workflow triggers, it runs the tasks in the background.









 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 06/22/2012 09:26 AM
User is offline View Users Profile Print this message

Author Icon
NixonJames
n00b (>6 posts)

Posts: 2
Joined: 06/22/2012

Leo, thanks for getting back to me promptly.

So that means if I change the option on "When workstation is logged off" to "Logon Specified user (defined below)", it should work, correct?



 Category Survey
 06/22/2012 09:41 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Yes that is correct as long as you have valid user credentials specified for logging on or unlocking the workstation.






 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1368 guests browsing this forum, which makes a total of 1368 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog