Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: "Not an object reference" all the time
Topic Summary:
Created On: 08/15/2011 01:42 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/15/2011 01:42 AM
User is offline View Users Profile Print this message

Author Icon
MortenSimonsen
Journeyman (50-99)

Posts: 72
Joined: 09/28/2010

Hi - I have a huge problem with my workflows, and it has gone worse within the last weeks.

I have workflows that runs in loops and they start with a task connecting to a SQL database and making a dataset (shared) with the data used in the workflow.

Sometimes they run fine for hours, but more and more often, I get the "Not an object reference" error, when using %dataset.value% someware in a task. It seems something is wrong with the dataset, but it is hard to find a pattern, it seems to appear randomly - where ever %dataset.value% is used.

What to do? - I cant find a way to solve this one ... 



 Category Survey
 08/15/2011 09:29 AM
User is offline View Users Profile Print this message

Author Icon
Rick Johnson
AUTOMATE EMPLOYEE

Posts: 2757
Joined: 07/14/2008

Hi Morten,

Are the SQL connections being closed?
If you open a connection, versus a 1 step SQL Query approach, it is advised to also close the connection once the data has been retrieved.

 Category Survey


-------------------------
- Rick Johnson
Network Automation
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1700 guests browsing this forum, which makes a total of 1700 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog