Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Could not register Ctrl+Alt+PageUp as hotkey.
Topic Summary: Issue running workflows with interactive logon
Created On: 09/19/2011 08:55 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/19/2011 08:55 AM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

Every time we try to run a workflow that interactively logs on to the desktop, we now get an error message in the Windows Event Log of "Could not register Ctrl+Alt+PageUp as hotkey."

This is affecting any workflow that requires an interactive logon to the desktop.



 Category Survey
 09/19/2011 09:34 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Hi Cory,

The event log message will not affect the logon process and is normal. It is simply notifying you that the hotkey is registered with another application already. This usually occurs when you have more than one Automate product installed. This is not related to any logon/unlock issues you may be experiencing.






 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 09/19/2011 10:33 AM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

Ok, where can I start looking for errors with the logon process?  I've tried existing workflows that have worked until this past Friday (when we started getting that error) and created new ones that should be logging on to a desktop session.  They all have zero interaction with the logon screen.  No Ctrl+Alt+Del sent at all.  I've started them manually, set them on a timer (and had all sessions logged off), and still nothing.

Also, we only have BPA Server 7 installed on this server.

Could a intrusion detection application stop BPA from logging on to a desktop session?  Our parent company has been known to install applications without our knowledge (like Blink if anyone has heard of it).

Thanks.



 Category Survey
 09/19/2011 11:01 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Hi Cory,

What version of Windows are you running? If you are not seeing a CTRL ALT DEL being sent to the workstation then it's possible that a domain policy was updated recently. Please double-click on ambpa32.exe from either of the following locations:

x86
C:\Windows\System32

x64
C:\Windows\SysWOW64

This executable should send a CTRL ALT DEL to your workstation.






 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 09/19/2011 11:05 AM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

No go with the ambpa32.exe... Just got a command prompt screen and then back to Windows Explorer.

I'm checking with our network team to see if anything was changed.  Do you know what I should specifically ask about for the domain policy?



 Category Survey
 09/19/2011 11:27 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Are you running Windows Vista or higher? Ambpa32.exe only works in Windows Vista, Windows 2008, and Windows 7. If you are not running any of those 3 operating systems then the problem is related to something else. If you are running one of those operating systems, then the first thing to check is UAC. Our executable requires UAC to be enabled in order to function properly.





 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 09/19/2011 11:56 AM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

Server2003... but it was working fine up until this past Friday.  So this makes me think that it's something else, like Blink.

I still have the network guys checking into that.  It does look like Blink may have been reinstalled... without our permission.

Does NA have any experience with the Blink product?



 Category Survey
 09/19/2011 01:19 PM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Unfortunately, we do not have any experience with Blink. Does it impair Windows logon?





 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 09/19/2011 01:50 PM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

Where does BPA try to register Ctrl+Alt+PageUp as a hotkey?  I have a simple workflow trying to use an interactive login and it throws this:

Event Type: Error
Event Source: AutoMate BPA Agent
Event Category: None
Event ID: 0
Date:  9/19/2011
Time:  4:46:38 PM
User:  N/A
Computer: VCUHSBPA
Description:
Could not register Ctrl+Alt+PageUp as hotkey.

This is every single time this workflow tries to run.  The logon functionality and trying to register Ctrl+Alt+PageUp is tied together somehow.



 Category Survey
 09/19/2011 01:54 PM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

The service registers the hotkey at startup. So everytime a workstation or service is restarted you will see this entry. Do you see the agent connecting in the logs prior to this entry?











 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 09/19/2011 02:16 PM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

I do not see the agent connecting in the logs.  The server has been up for 137 days (I know... forever in the Windows world), so there was not a startup this past Friday.  Also, this entry is in the logs as least 1000+ times over the past four days (and ONLY the past four days).

Other notes:
BPA Agent and Service are both running OK.  We have workflows that are running perfectly fine, as long as they are not logging on interactively.



 Category Survey
 09/19/2011 03:00 PM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

As a test, change the hotkey setting for BPA and let's see if the problem persists.








 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 09/19/2011 03:12 PM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

I'm not sure what hotkey setting I need to change.  Are you talking about a Key Event?  This is a BPA workflow that doesn't have a Key Event.  I searched the documentation but couldn't find where to change a hotkey setting other than for a Key Event.



 Category Survey
 09/19/2011 03:14 PM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

It's in your Options pane of the SMC. Click on Default Properties and then Indicators. Then either unselect 'enable the task interruption hotkey' or change the hotkey.





 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 09/19/2011 03:25 PM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

No dice on that either... I think I'm about done for the night and will give this thing a restart tomorrow.

Thanks for the help and quick responses!



 Category Survey
 09/19/2011 03:29 PM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

It might be set at the specific agent then. Check the indicator properties for that particular agent and see if the problem persists.







 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 09/20/2011 06:27 AM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

The indicator properties for the Agent were inherited.

I'm rebooting the server at 10:30am so we'll see what we get after that...



 Category Survey
 09/20/2011 07:55 AM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

Looks like the server reboot did the trick.  I'll be getting this server on a regular reboot cycle to try and avoid this in the future.

 

Thanks for all of your help Leonard!



 Category Survey
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1388 guests browsing this forum, which makes a total of 1388 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog