Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Server Crashed - DR
Topic Summary: Disaster Recovery
Created On: 12/21/2011 10:21 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/21/2011 10:21 AM
User is offline View Users Profile Print this message

Author Icon
KunalKeshav
Apprentice (20-49)

Posts: 27
Joined: 06/29/2006

Our server crashed and we are trying to restore Automate BPA from tape. The new Server has a different name and when I try to connect to the localhost in the management console I receive "Connection attempts to localhost failed". Where can I change the connection string to the new SQL Server name?

Thanks

 Category Survey
 12/21/2011 11:27 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Is just the SQL server name changed or the BPA server as well?





 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 12/21/2011 11:42 AM
User is offline View Users Profile Print this message

Author Icon
KunalKeshav
Apprentice (20-49)

Posts: 27
Joined: 06/29/2006

Hi Leonard,

The BPA server name has changed and SQL server is running local.

 Category Survey
 12/21/2011 02:42 PM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Hi Kunal,

What version of Windows are you running? Please shut down the Automate BPA 7 Server and Agent services and edit the Server Properties.xml file.

Windows XP; Windows 2003
C:\Documents and Settings\All Users\Application Data\Network Automation\AutoMate BPA Server

Windows Vista, Windows 2008, Windows 7
C:\ProgramData\Network Automation\AutoMate BPA Server

Please change the following line in the .xml file: (see attached code below)

It may read something else other than OleDb. Once you have made the change, save and close the file and then restart the services. Open the SMC and you should now be able to connect to the server. Now that you are connected, please adjust the data store configuration to point to your SQL server. Please DO NOT migrate data if prompted. Then follow the other prompts to restart the services. Let me know if the problem persists.



 Category Survey



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 12/22/2011 11:06 AM
User is offline View Users Profile Print this message

Author Icon
KunalKeshav
Apprentice (20-49)

Posts: 27
Joined: 06/29/2006

Thanks to you Leonard I was able to connect after modifying the XML file and following your directions, but after I set my data store back to SQL Server via the SMC console and restart the services I am unable to log in via my administrator account with password. Is there any way to reset the admin password?

 Category Survey
 12/22/2011 11:26 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Hi Kunal,

Do you use SQL Server Management Studio? You can edit the password for administrator in the userconstructs table. The password will be encrypted. Shutdown your BPA services first and then set your password in plain text in the database. Then start the services and login from the SMC. The password will remain in plain text in the database until you set it from within the SMC.







 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 12/22/2011 12:15 PM
User is offline View Users Profile Print this message

Author Icon
KunalKeshav
Apprentice (20-49)

Posts: 27
Joined: 06/29/2006

Hi Leonard,

We tried stopping the services, resetting the password to plain text, starting the services and still no luck entering credentials.

 Category Survey
 12/22/2011 02:54 PM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Hi Kunal,

We may need to schedule a remote session to help you correct this. Please send your availability to support@networkautomation.com and reference this thread.






 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1771 guests browsing this forum, which makes a total of 1771 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog