Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: SFTP with Password and Public Key Not Working
Topic Summary: SFTP with Password and Public Key Not Working
Created On: 02/21/2013 02:35 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/21/2013 02:35 PM
User is offline View Users Profile Print this message

Author Icon
BillBates
Student (5-19 posts)

Posts: 13
Joined: 05/27/2011

We are running AutoMate BPA Server 8, Enterprise Edition, 8.0.1.10.

I am attempting to establish connectivity with a new trading partner that requires SFTP with both a password and a public key.

I have setup the FTP logon with a connection type of SFTP (Key) and provided both a password and our private key file.

When I attempt to connect to the FTP site is get "FTP Error : Connection lost (error code is 10058)" and the FTP log file contains the following...

------------------------------------------------------------------------
Date : 2/21/2013 3:37:35 PM
------------------------------------------------------------------------
Connecting to qadatatransfer.rbs.com connection type is sftp_public_key
Server key [b2b8011f633c46b943ae28d824e954ce] received
Authentication type [2] used
Authentication type [2] used
Authentication type [2] failed
Error 114


With the ftp logon configured this way, i.e. connection type of SFTP (Key) with both a password and our private key file, are both the password and key being utilized/sent?

Is there somethng else I need to do to connect successfully?


 Category Survey
 02/22/2013 03:25 PM
User is offline View Users Profile Print this message

Author Icon
BillBates
Student (5-19 posts)

Posts: 13
Joined: 05/27/2011

Our new trading partner has agreed to allow us to establish the connect with only the key, i.e. no password.

As a result, the SFTP (Key) connection type is now working fine.

 Category Survey
 02/22/2013 03:27 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Bill,

I apologize for the delay and I am happy to hear that you are running, Thank you for the update.

 Category Survey
AutoMate 8 version:
Windows version:


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 11/08/2016 04:58 PM
User is offline View Users Profile Print this message

Author Icon
AdrianAcuna
Journeyman (50-99)

Posts: 94
Joined: 05/29/2010

I had this same problem. It seems that the remote server supports PW or PKA and when Automate tried to connect, it tried to send both, even though I only wanted it to use Public Key. Is there a way to prevent this behavior?

 Category Survey
AutoMate 8 version:
Windows version:


-------------------------
Adrian Acuña
Sales Engineer
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 910 guests browsing this forum, which makes a total of 910 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog