Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: SFTP error when connecting via key exchange
Topic Summary:
Created On: 05/22/2013 09:15 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/22/2013 09:15 AM
User is offline View Users Profile Print this message

Author Icon
AndrewReynolds
n00b (>6 posts)

Posts: 3
Joined: 02/20/2013

I am seeing errors with jobs that use SFTP via key exchange lately. It started in out production environment which for the next few weeks will remain on 8.0.1.10. This has also started to occur in our UAT environment (8.0.9.0). Any suggestions with regards to resolving this would be appreciated. 

 

 

1.) 8.0.9.0
2.) Windows Server 2003 Enterprise Edition.
3.) Error Messages from Automate and Event Viewer.

------------------------------------------------------------------------

Date : 22/05/2013 16:48:02

------------------------------------------------------------------------

Connecting to cpbswz4cqua1.nam.nsroot.net connection type is sftp_public_key

Server key [1fd482a682727703de91d4c418f45fcb] received

Error 105

Time of error: 22/05/2013 16:48:48

Error message: FTP Error : Connection lost (error code is 10058) Computer name: 

4.) Reproduction Instructions.

In our environment this occurs each time we run the jobs that use sftp with key exchange although it used to work. 
5.) Task Steps (if applicable). Use the "attach code" button to include steps. 

Retries and delays added in troubleshooting attempt.



 Category Survey



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)
 05/23/2013 01:57 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Andrew,

Did this connection work in the past? If so has anything changed?

 Category Survey
AutoMate 8 version:
Windows version:


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 05/27/2013 05:02 AM
User is offline View Users Profile Print this message

Author Icon
AndrewReynolds
n00b (>6 posts)

Posts: 3
Joined: 02/20/2013

Hi Ricardo,

Yes, it did work in the past. I am not directly aware of any changes but there are MS patches applied to all servers in accordance with security directives here in the company. I'm trying to ascertain what changes were made, if any, around the time that this stopped working.

 

I'm curious to know though, what is the following error 

Connecting to cpbswz4cqua1.nam.nsroot.net connection type is sftp_public_key

Server key [1fd482a682727703de91d4c418f45fcb] received

Error 105

This appears to occur before error 10058.

 

Any suggestions for additional troubleshooting? 



 Category Survey
 05/28/2013 12:08 PM
User is offline View Users Profile Print this message

Author Icon
Liz Casale
AUTOMATE EMPLOYEE

Posts: 940
Joined: 05/23/2011

Hi Andrew,

Would it be possible for you to download and install AutoMate v9 along side v8 for testing purposes? v9 exposed additional authentication types. In this case, you may need to specify for public key authentication.

AutoMate 9 Download

Please let us know your results.

If downloading v9 is not an option, would it be possible to schedule a GoToAssist session so that we can review the task running on your machine? For this option, please email support@networkautomation.com referencing this forum post and your availability.

 Category Survey


-------------------------
Liz Casale
Technical Support Representative
(213) 738-6966
Network Automation, Inc.

--------------------------------------------------------------------------------

AM5 5.5.5.1; AM6 6.2.8.0; AM7 7.1.3.0; AM8 8.0.9.0; AM9 9.0.3.4
BPA7 7.1.3.0; BPA8 8.0.9.0; BPA9 9.0.3.4
 06/14/2013 07:42 AM
User is offline View Users Profile Print this message

Author Icon
AndrewReynolds
n00b (>6 posts)

Posts: 3
Joined: 02/20/2013

Hello Liz,

 

Installing V9 may be problematic due to controls and compliance but will see what I can do. Apologies for the delayed reply, after a long wait with user testing initiatives I am poised to upgrade v8.0.1.10 to 8.0.9.0 tomorrow morning. I'll come back on this during the coming week with either a parallel run of 8 an 9 side by side or arrange for GoToAssist. Are any components required to be installed for GoToAssist by the vendor (Citrix I believe?). 

 

Regards,

 

Andrew



 Category Survey
 06/14/2013 04:14 PM
User is offline View Users Profile Print this message

Author Icon
Liz Casale
AUTOMATE EMPLOYEE

Posts: 940
Joined: 05/23/2011

Hi Andrew,

Thank you for the follow up. We use a program called GoToAssist Express. Here are the system requirements:

System Requirements

To join a support session, the following are required:

PC: Windows® XP, Windows Server 2003, Windows Vista, Windows Server 2008 or Windows 7

Internet Explorer® 7.0 or newer, Firefox® 3.0 or newer, or Safaritm 3.0 or newer
Javatm 1.6 or newer highly recommended
Stable Internet connection (56k or better recommended)
Ability to make direct outgoing TCP connections or availability of an HTTP proxy or a SOCKS server

 Category Survey


-------------------------
Liz Casale
Technical Support Representative
(213) 738-6966
Network Automation, Inc.

--------------------------------------------------------------------------------

AM5 5.5.5.1; AM6 6.2.8.0; AM7 7.1.3.0; AM8 8.0.9.0; AM9 9.0.3.4
BPA7 7.1.3.0; BPA8 8.0.9.0; BPA9 9.0.3.4
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 2218 guests browsing this forum, which makes a total of 2218 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog