Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Webservice - Token & Arrays
Topic Summary:
Created On: 08/29/2013 10:33 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/29/2013 10:33 AM
User is offline View Users Profile Print this message

Author Icon
JeffTysco
Artisan (200-499)

Posts: 319
Joined: 07/30/2009

I'm working with a new vendor who allows me to utilize a webservice to download reports, as well as a bunch of other calls I can make use of...however they are requiring a token that contains arrays to authenticate the account.

Any thoughts on how I can perform the following actions in AM?

The following code below is how to build the token (I copied their PHP Example, but they also have a .NET and C example as well if it helps

 Category Survey



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)


-------------------------
?? . Your Total IT Solutions Provider
?? . Business Class Hosting Services
 08/29/2013 10:35 AM
User is offline View Users Profile Print this message

Author Icon
JeffTysco
Artisan (200-499)

Posts: 319
Joined: 07/30/2009

The following code attachment shows the WSDL call and the parameters. This should be easy to figure out since the parameters appear in the arguments tab

 Category Survey



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)


-------------------------
?? . Your Total IT Solutions Provider
?? . Business Class Hosting Services
 09/03/2013 10:19 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Jeff,

Would it be possible to setup a GoToAssist session where we can take a closer look at this issue? If this is possible please send an email over to support@networkautomation.com with a list of your availability.

Note: Please reference this forum thread in your email.


 Category Survey
AutoMate 8 version:
Windows version:


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1851 guests browsing this forum, which makes a total of 1851 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog