Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Twoway-SSL certification using Web Service Request
Topic Summary:
Created On: 04/10/2014 02:03 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/10/2014 02:03 AM
User is offline View Users Profile Print this message

Author Icon
MaxBergqvist Edman
n00b (>6 posts)

Posts: 3
Joined: 04/10/2014

Hello,

I'm quite new to AutoMate, so sorry if this question is stupid. But I need some help.

I'm using AutoMate version v8.0.9.0 on a Windows 7 machine.

My problem is that I have encountered an Error from the "Execute Web Service" function. The errormessage is:
[Main](Step 1) Web Service Error : The request was aborted: Could not create SSL/TLS secure channel. "

I'm trying to connect to a web service that uses a twoway-SSL certification. I'm possible to supply the information where i have my clientcertificate. But the function does not succed, and I believe that the problem is that the trust-certificate isn't displayed for AutoMate. Is there any way to do this?

At the moment I'm using a Java-based client to request information from the webservice. My wish is to automate this, and take the client out of use. I have my certificates stored in a keyStore and a trustStore by the format .jks. Used by the Java-client.

How do I apply this into the "Execute Web Service" function in AutoMate.

Thanks in advance.
Yours sincerely
Max Bergqvist Edman



 Category Survey
AutoMate 8 version:
Windows version:
 04/15/2014 10:34 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Max,

Would it be possible to set-up a GoToAssist session where we can take a closer look at this issue? If this is possible please send an email over to support@networkautomation.com with a list of your availability.

Note: Please reference this forum thread in your email.


 Category Survey
AutoMate 8 version:
Windows version:


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 04/16/2014 04:08 AM
User is offline View Users Profile Print this message

Author Icon
MaxBergqvist Edman
n00b (>6 posts)

Posts: 3
Joined: 04/10/2014

Hi,

The best solution for me is if you could explain the way to do it in text? If this is possible at all?

Otherwise, how do a GoToAssist session work? Is it by remote control or how is it planned to work?

Thanks

/Max



 Category Survey
AutoMate 8 version:
Windows version:
 04/16/2014 08:51 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Max,

We would send you a link to join our GoToAssist session. You will connect from your Local machine and we will be able to view your screen and troubleshoot from there.

 Category Survey
AutoMate 8 version:
Windows version:


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 04/16/2014 11:28 PM
User is offline View Users Profile Print this message

Author Icon
MaxBergqvist Edman
n00b (>6 posts)

Posts: 3
Joined: 04/10/2014

Hello,

Well, OK. Sounds good. I'll send a mail to support@networkautomation.com .

Thanks!



 Category Survey
AutoMate 8 version:
Windows version:
 04/28/2014 03:23 PM
User is offline View Users Profile Print this message

Author Icon
Alex Escalante
HelpSystems

Posts: 871
Joined: 02/26/2014

Hello Max,

After speaking with our development team, we would like for you to test this action in AutoMate v. 9.0.4.5

Please try this on AM9 and let us know your results.

 Category Survey


-------------------------

Alex Escalante | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1254 guests browsing this forum, which makes a total of 1254 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog