Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Encrypt step throwing error: An attempt was made to reference a token that does not exist
Topic Summary:
Created On: 02/19/2018 06:51 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/19/2018 06:51 AM
User is offline View Users Profile Print this message

Author Icon
MattSmith
n00b (>6 posts)

Posts: 3
Joined: 05/09/2017

I have an automate task that fails when my server is up for 5+ days. This task runs many times throughout the day.

I see the following error in the logs:
TASKFAILURE 46 An unhandled error has occurred Cryptographic process failed with error An attempt was made to reference a token that does not exist

Any idea what this points to?

Thanks.

 Category Survey
 02/20/2018 09:58 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello Matt,

What is the state of the machine when it fails?

What else does the task do?

 Category Survey
AutoMate 8 version:
Windows version:


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 02/20/2018 11:45 AM
User is offline View Users Profile Print this message

Author Icon
MattSmith
n00b (>6 posts)

Posts: 3
Joined: 05/09/2017

The machine state is fine. Nothing out of the ordinary except for running automated processes with EFT and workflows. This particular AWE creates around 20 variables, does a quarry on SQL DB, loops through the dataset to build a file, and encrypts the file. After this encrypt we move it to an archive folder and delete the source. It just recently started seeing the behavior on the encrypting step on multiple AWE's.

This is the aml of the AWE step:

 Category Survey



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)


Edited: 02/23/2018 at 07:16 AM by AutoMate Discussion Moderator
 02/23/2018 12:37 PM
User is offline View Users Profile Print this message

Author Icon
Alex Escalante
HelpSystems

Posts: 871
Joined: 02/26/2014

Hello Matt,

When you receive the error message, can you rerun the task and then have it work successfully? In other words, does the key actually encrypt the file?

What version of 8 are you running? 809?

 Category Survey


-------------------------

Alex Escalante | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 929 guests browsing this forum, which makes a total of 929 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog