Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: file condition
Topic Summary: file condition triggers without new file
Created On: 07/11/2013 08:30 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/11/2013 08:30 AM
User is offline View Users Profile Print this message

Author Icon
JamesKing
Student (5-19 posts)

Posts: 6
Joined: 08/19/2005

i have designed a simple workflow where
file condition watch new file added and sent email notification. but sometime i am getting error. i am getting lots of emails without adding new files in the folder. it triggers for old files also.

i have set the following condition in file condition.

General
check on include subfolders
check on wait for file to be accessible
polling interval for remote folders (5 seconds)

Prerequisites
file added to the folder

behavior
check waitfor condition (indefinitely)
check trigger on startup if condition is true


 Category Survey
 07/12/2013 10:14 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi James,

Would it be possible to post a dummy workflow with the actual trigger?

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 07/13/2013 01:00 PM
User is offline View Users Profile Print this message

Author Icon
JeanDelfosse
Supreme Guru (1000+)

Posts: 8883
Joined: 03/30/2005

James,
could it be that the remote server where the watched folder resides is sometimes turned off then on ?
In such a case the trigger will see the remote folder disappear and then come back which could cause trigger for all files therein wrongly taken as brand new, including the old ones ?

 Category Survey
AutoMate BPA Server 8 version:
Windows version:


-------------------------
Jean Delfosse - Automate Beta Tester
Win7 Pro 64 bits -Win XP Pro SP3 32 bits - AM8, AM7, BPA10, BPA9, BPA8, BPA7, AM6 Enterprise, AM4
 07/17/2013 11:44 AM
User is offline View Users Profile Print this message

Author Icon
JamesKing
Student (5-19 posts)

Posts: 6
Joined: 08/19/2005

in general tab polling interval for remote folders was (5 seconds) i have increased it to 10 seconds i hope this will solve problem . let's see if it does not work i'll ask you again.
Thanks

 Category Survey
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1420 guests browsing this forum, which makes a total of 1420 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog