Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Illegal Characters in Path
Topic Summary:
Created On: 11/08/2011 09:43 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/08/2011 09:43 AM
User is offline View Users Profile Print this message

Author Icon
AngelaCraig
n00b (>6 posts)

Posts: 5
Joined: 11/08/2011

I am converting workflows from BPA 7 to BPA 8.  While working with the FTP portion, I have ran into a problem.  I have placed variables to have my destination and remote path.  When I pick them in the FTP action and run the workflow, I get an error - "An unhandled error has occurred (Error: Illegal characters in path.)

Below is the AML code.  Can anyone assist?

 



 Category Survey



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)
 11/08/2011 11:04 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Angela,

Would it be possible to setup a GoToAssist session so that we can take a closer look at this issue? If so please send a list of times and days that you are free to support@networkautomation.com


 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 11/09/2011 10:01 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

During our GoToAssist session we were able to determine that the issue was caused by the user not having access the "Destination Path".

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 11/14/2011 08:02 AM
User is offline View Users Profile Print this message

Author Icon
CorySwartz
Expert (100-199)

Posts: 133
Joined: 02/11/2010

One additional note: once the issues with permissions were fixed, we still ran into the Illegal Characters in Path errors.  After checking the BPA Task, we noticed that there was an extra carriage return in the destination variable.  Once we removed that carriage return, the Task ran successfully.



 Category Survey
 09/25/2015 12:57 PM
User is offline View Users Profile Print this message

Author Icon
MaggieFogarty
n00b (>6 posts)

Posts: 4
Joined: 09/15/2015

I just had this exact same issue and the only thing I needed to change to fix it was making sure the destination path was accessible to the FTP user.  Thank you this topic was very helpful!



 Category Survey
AutoMate BPA Server 8 version:
Windows version:
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1073 guests browsing this forum, which makes a total of 1073 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog