Network Automation Software
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Webbrowser session in IE tabs
Topic Summary:
Created On: 01/12/2012 12:17 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/12/2012 12:17 AM
User is offline View Users Profile Print this message

Author Icon
AndreasHeydeck
Apprentice (20-49)

Posts: 26
Joined: 10/22/2009

Hey,

Using IE8 (havent tried IE7/9 because our organisation use IE8), create session for a browser tab works only if that was the first opened tab. However, if i open tab #2 and try to get that session with the webbrowser object in bpa is rendering an error in bpa that says it cant find the window.

Does anyone have a solution or a workaround for this problem?

//Andreas



 Category Survey
 01/12/2012 09:13 AM
User is offline View Users Profile Print this message

Author Icon
Gijsberth de Ruiter
Artisan (200-499)

Posts: 455
Joined: 03/30/2005

you will have to add some 'browser wait' actions in between the other actions (just a few secs). The pages are probably not loaded.

 Category Survey


-------------------------
I am an A-Team Member
 01/13/2012 02:56 AM
User is offline View Users Profile Print this message

Author Icon
AndreasHeydeck
Apprentice (20-49)

Posts: 26
Joined: 10/22/2009

Hi,

Thanks for the answer, however, it isnt working. Can we set up a remote session to show you?

// Andreas



 Category Survey
 01/13/2012 03:15 AM
User is offline View Users Profile Print this message

Author Icon
JeanDelfosse
Supreme Guru (1000+)

Posts: 8883
Joined: 03/30/2005

Adreas,
if you use new windows instead of new tabs, does it work ?

 Category Survey
AutoMate BPA Server 8 version:
Windows version:



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)


-------------------------
Jean Delfosse - Automate Beta Tester
Win7 Pro 64 bits -Win XP Pro SP3 32 bits - AM8, AM7, BPA10, BPA9, BPA8, BPA7, AM6 Enterprise, AM4
 01/13/2012 12:30 PM
User is offline View Users Profile Print this message

Author Icon
Liz Casale
AUTOMATE EMPLOYEE

Posts: 940
Joined: 05/23/2011

Andreas,

BPA Server will only see the first tab of an open browser. The web browser actions will not work with multiple tabs.

 Category Survey


-------------------------
Liz Casale
Technical Support Representative
(213) 738-6966
Network Automation, Inc.

--------------------------------------------------------------------------------

AM5 5.5.5.1; AM6 6.2.8.0; AM7 7.1.3.0; AM8 8.0.9.0; AM9 9.0.3.4
BPA7 7.1.3.0; BPA8 8.0.9.0; BPA9 9.0.3.4
 01/16/2012 12:16 AM
User is offline View Users Profile Print this message

Author Icon
AndreasHeydeck
Apprentice (20-49)

Posts: 26
Joined: 10/22/2009

Ah that explains it. Is this working with v9?



 Category Survey
 01/16/2012 01:09 AM
User is offline View Users Profile Print this message

Author Icon
JeanDelfosse
Supreme Guru (1000+)

Posts: 8883
Joined: 03/30/2005

Andreas,
Web browser action seems working (with a few bugs maybe) with BPA9 and IE9.

 Category Survey
AutoMate BPA Server 8 version:
Windows version:


-------------------------
Jean Delfosse - Automate Beta Tester
Win7 Pro 64 bits -Win XP Pro SP3 32 bits - AM8, AM7, BPA10, BPA9, BPA8, BPA7, AM6 Enterprise, AM4
 01/16/2012 05:54 AM
User is offline View Users Profile Print this message

Author Icon
AndreasHeydeck
Apprentice (20-49)

Posts: 26
Joined: 10/22/2009

Really? What kind of bugs did you experience?

// Andreas



 Category Survey
 01/16/2012 07:17 AM
User is offline View Users Profile Print this message

Author Icon
JeanDelfosse
Supreme Guru (1000+)

Posts: 8883
Joined: 03/30/2005

Andreas,
If you search this forum for "browser" in AM9 and BPA9 sections, you will see them documented.

 Category Survey
AutoMate BPA Server 8 version:
Windows version:


-------------------------
Jean Delfosse - Automate Beta Tester
Win7 Pro 64 bits -Win XP Pro SP3 32 bits - AM8, AM7, BPA10, BPA9, BPA8, BPA7, AM6 Enterprise, AM4
Statistics
18257 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 6686 on 11/01/2020 at 01:24 AM.
There are currently 540 guests browsing this forum, which makes a total of 540 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2021 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog