Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Dropdown box values can change
Topic Summary:
Created On: 12/12/2014 07:37 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/12/2014 07:37 AM
User is offline View Users Profile Print this message

Author Icon
SamSpritzer
Apprentice (20-49)

Posts: 38
Joined: 04/25/2014

I have a dropdown box which I use the Interactivity - Move mouse to object (along with Press) action.  As you can see from the code, it appears the best question Automate can make is to match is the OBJECTNAME. 

This however, can be manipulated by the user.  This is a dropdown box that allows the user to select a view to use for the dataset to be displayed.  The user can also control how the dataset looks (add, remove columns).  And they can save this new view.

When that happens and it gets added to the dropdown, it breaks the action because the new view gets added.  In essence, if we were to rebuild the step, the OBJECTNAME would look like...
OBJECTNAME="* TAS Default * 7 Day View (Alerts) * 7-Day View * Default Alerts View * Since Last View * Since Last View (Alerts) * Today View * Today View (Alerts) + TAS Exports + MY NEW VIEW"
...where + MY NEW VIEW is the new view the user adds.  Since that doesn't match what we built, Automate will fail.

Is there anyway to use wildcards so that no matter what, Automate recognizes + TAS Exports?  That is the view that I am trying to use in the process.  I have attached the complete code for the step.

Thanks!




Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)
 12/12/2014 09:45 AM
User is offline View Users Profile Print this message

Author Icon
SamSpritzer
Apprentice (20-49)

Posts: 38
Joined: 04/25/2014

I found a solution.  I was able to accomplish this by using the Web Browser set value action.

Thanks!

Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 933 guests browsing this forum, which makes a total of 933 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog