Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Pass the name / id of the agent to execute the workflow command-line utility
Topic Summary: Useful to create a desktop shortcut that runs a workflow on a specific agent
Created On: 12/04/2013 10:22 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/04/2013 10:22 AM
User is offline View Users Profile Print this message

Author Icon
HerminioPereira
Journeyman (50-99)

Posts: 51
Joined: 07/24/2012

According documentation on command-line utility, the  section "Workflow Execution Parameters" informs: "Because a workflow should already contain the tasks as well as the Agents/Agent Groups that the task should run on, there is no need to enter task or agent information.".

Consider the following scenario:

There's a workflow where all tasks are set to run on the "triggered agent" and is launched by a key event condition set to an agent group.

When key combination is pressed on a group agent, the tasks run at this agent.

However, if this workflow runs by command-line utility (AMExecute.exe), the tasks are send to default group agent, when the desirable behavior is send the tasks to the agent that calls AMExecute.exe

I would suggest an option for workflow execution through command-line utility, that is to accept a parameter to inform the agent name or id, and assume it as "triggered agent".

This "new" behavior could be useful to create a desktop shortcut that runs a workflow by an easier manner.

Thank you in advance for your attention, and thanks / blame Google Translator by translation.

Best regards,

Herminio Pereira

 12/06/2013 03:11 PM
User is offline View Users Profile Print this message

Author Icon
Valentineo McGowan
HelpSystems

Posts: 766
Joined: 09/03/2013

Hello Herminio,

Thank you for your observation and the great suggestion!

-------------------------

Valentineo McGowan | Technical Consultant
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1 213.738.6966 | F: +1.213.738.7665
 05/18/2015 11:33 AM
User is offline View Users Profile Print this message

Author Icon
HerminioPereira
Journeyman (50-99)

Posts: 51
Joined: 07/24/2012

Originally posted by: Valentineo McGowan Hello Herminio, Thank you for your observation and the great suggestion!

 

Hello Valentineo!

Is there a feature request # for this input?

 05/19/2015 02:48 PM
User is offline View Users Profile Print this message

Author Icon
Mary Manzano
HelpSystems

Posts: 280
Joined: 03/10/2014

Hello Herminio,

 

I was unable to find the suggestion in our database. I will be glad to re-enter this for you. May you please explain the request a bit more? An example with screenshots will be very helpful.

 



-------------------------
Mary Manzano | Technical Consultant
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 07/01/2015 03:54 PM
User is offline View Users Profile Print this message

Author Icon
HerminioPereira
Journeyman (50-99)

Posts: 51
Joined: 07/24/2012

Hello Mary,

 

See attached file for detailed examples.

If you have additional questions, feel free to ask.




 07/08/2015 10:02 AM
User is offline View Users Profile Print this message

Author Icon
Valentineo McGowan
HelpSystems

Posts: 766
Joined: 09/03/2013

Hello Herminio,

This has been forwarded on to our Development team. When a Feature Request# has been generated I will update this forum thread.
Thank you for your patience and your assistance in bringing this to the attention of our Technical Support staff.

-------------------------

Valentineo McGowan | Technical Consultant
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1 213.738.6966 | F: +1.213.738.7665
 07/14/2015 12:11 PM
User is offline View Users Profile Print this message

Author Icon
Valentineo McGowan
HelpSystems

Posts: 766
Joined: 09/03/2013

Hello Herminio,

We are aware of this behavior and are presently in the process of correcting it.
F636 | AMEXECUTE: Manually Run workflow execution through AMExecute
Thank you for your patience and your assistance in bringing this matter to our Technical Support staff.

-------------------------

Valentineo McGowan | Technical Consultant
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1 213.738.6966 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 818 guests browsing this forum, which makes a total of 818 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog