Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: HRCHECK error at subtask completion
Topic Summary:
Created On: 04/11/2012 12:35 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/11/2012 12:35 PM
User is offline View Users Profile Print this message

Author Icon
TrevorJager
Artisan (200-499)

Posts: 211
Joined: 04/13/2005

I have a multi-task Task that errors with a HRCHECK error and Task Builder hangs.

The HRCHECK error is attached.

An External exception EEFFACE then occurs.

This is occurring on a Windows XP system with version 9.0.1.11.

A very simplified version of what I am doing is:
Task 1 calls Task 2, which then calls Task 3. When task 3 is on the last active Step, Task Builder stalls and the HRCHECK error appears.



 Category Survey


Click for full image
Click for larger image



-------------------------
Trevor Jager
Principal Engineer
PeopleNet

Automate 9.0.4.5
Automate 11.0.1.17
Windows 7, Windows 10
 04/11/2012 01:25 PM
User is offline View Users Profile Print this message

Author Icon
TrevorJager
Artisan (200-499)

Posts: 211
Joined: 04/13/2005

I have attached a zipped swf video of what I am seeing on the system. When it stalls on the third task, it never recovers on its own.

 Category Survey


HRCHECK.zip
HRCHECK.zip  (2738 KB)



-------------------------
Trevor Jager
Principal Engineer
PeopleNet

Automate 9.0.4.5
Automate 11.0.1.17
Windows 7, Windows 10
 04/12/2012 01:54 PM
User is offline View Users Profile Print this message

Author Icon
TrevorJager
Artisan (200-499)

Posts: 211
Joined: 04/13/2005

This particular issue turned out to be another dataset error, although there were no descriptive events to show that was the case. We have now been able to work around this particular situation, but it would be extremely helpful to see
1st - that an error actually occurred and not just hang AM
2nd - What the cause of the error was so it can be corrected


 Category Survey


-------------------------
Trevor Jager
Principal Engineer
PeopleNet

Automate 9.0.4.5
Automate 11.0.1.17
Windows 7, Windows 10
 04/12/2012 02:05 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Trevor,

Would it be possible to post a smaller test case that we can use to reproduce the issue in house?

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 04/12/2012 03:38 PM
User is offline View Users Profile Print this message

Author Icon
TrevorJager
Artisan (200-499)

Posts: 211
Joined: 04/13/2005

Here are the sample files.

The names changed from Task 1.aml to Task 11.aml and
Task 2.aml to Task 21.aml.

It is best to see it running from TB, so run Task 1 first. The last step in Task 2 should stall. If you press stop, it will

Please save the files in your c:\ directory and rename them properly again. You will need Excel to run this.

Thanks,


 Category Survey


Task 11.aml
Task 11.aml  (1 KB)
Task 21.aml
Task 21.aml  (1 KB)



-------------------------
Trevor Jager
Principal Engineer
PeopleNet

Automate 9.0.4.5
Automate 11.0.1.17
Windows 7, Windows 10

Edited: 04/12/2012 at 04:08 PM by TrevorJager
 04/13/2012 03:26 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Trevor,

I was able to successfully run your tasks. Can you please confirm that this issue occurs on version 9.0.1.11?

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 04/16/2012 06:36 AM
User is offline View Users Profile Print this message

Author Icon
TrevorJager
Artisan (200-499)

Posts: 211
Joined: 04/13/2005

It is version 9.0.1.11.

Attached is the error that appears on the screen.


 Category Survey


Click for full image
Click for larger image



-------------------------
Trevor Jager
Principal Engineer
PeopleNet

Automate 9.0.4.5
Automate 11.0.1.17
Windows 7, Windows 10
 04/17/2012 10:26 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Trevor,

Are you using the same task that you originally posted?

Would it be possible to see this behavior first hand? If so please send an email to support@networkautomation.com with your availability.

Note: Please reference this forum thread in your email.


 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 04/17/2012 10:54 AM
User is offline View Users Profile Print this message

Author Icon
TrevorJager
Artisan (200-499)

Posts: 211
Joined: 04/13/2005

It is the same task that I originally posted. I have sent an email in regards to availability.

 Category Survey


-------------------------
Trevor Jager
Principal Engineer
PeopleNet

Automate 9.0.4.5
Automate 11.0.1.17
Windows 7, Windows 10
 04/17/2012 02:12 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Trevor,

We will follow up via email and take a closer look at this issue.

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 789 guests browsing this forum, which makes a total of 789 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2018 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog