Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Oracle 11g unable to connect
Topic Summary: A dynamic link library (DLL) initialization routine failed
Created On: 09/25/2013 02:42 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/25/2013 02:42 PM
User is offline View Users Profile Print this message

Author Icon
RyanCarbello
Student (5-19 posts)

Posts: 11
Joined: 09/25/2013

I get a Microsoft Data Link Error

Test connection failed because of an error in initializing provider.

Specified driver could not be loaded due to system error 1114: A dynamic link library (DLL) initialization routing failed. (Oracle in OraClient11g_home1, C:\app\user\product\11.2.0\client_2\BIN\SQORA32.DLL).



 Category Survey
AutoMate 9 version:
Windows version:
 09/26/2013 08:00 AM
User is offline View Users Profile Print this message

Author Icon
N i c k
Expert (100-199)

Posts: 183
Joined: 03/11/2006

You need to select "Oracle Provider for OLE DB"

On your attachment (page 5) you selected 'Microsoft OLE DB Provider for ODBC Drivers'



 Category Survey
 09/26/2013 08:04 AM
User is offline View Users Profile Print this message

Author Icon
N i c k
Expert (100-199)

Posts: 183
Joined: 03/11/2006

Also - Try the following if still not working.

Download and install 32 bit oracle client. After installing and setting up env var for example path and tns_admin. Restart machine. Open Automate TA and go over to system options and add new connections.

Env var for path should be auto setup as part of Oracle client setup. The trick to getting it to work was making sure TNS_ADMIN was set and you must restart.

If nothing else try restarting the machine.

 Category Survey
 09/26/2013 12:43 PM
User is offline View Users Profile Print this message

Author Icon
RyanCarbello
Student (5-19 posts)

Posts: 11
Joined: 09/25/2013

How do I setup up env var for example path and tns_admin?



 Category Survey
AutoMate 9 version:
Windows version:
 09/26/2013 02:15 PM
User is offline View Users Profile Print this message

Author Icon
RyanCarbello
Student (5-19 posts)

Posts: 11
Joined: 09/25/2013

This is the error I'm getting when I use "Oracle Provider for OLE DB"



 Category Survey
AutoMate 9 version:
Windows version:
 09/26/2013 10:50 PM
User is offline View Users Profile Print this message

Author Icon
N i c k
Expert (100-199)

Posts: 183
Joined: 03/11/2006

Ryan, I should of asked you do you even use Tnsnames.ora file?

If you don't use you don't need to setup env var.


Question: What is the tns_admin parameter and how do I use tns_admin to define a common location for my TNS files?


Answer: The tns_admin parameter determines the location of the tns administration files (e.g. tnsnames.ora and listener.ora, etc.)


See the following link:
http://kb.tableausoftware.com/...base/oracle-connection

 Category Survey
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 676 guests browsing this forum, which makes a total of 676 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog