Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Focus Window Not Working When Unattended
Topic Summary:
Created On: 11/15/2016 12:23 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/15/2016 12:23 PM
User is offline View Users Profile Print this message

Author Icon
MarkLee
Student (5-19 posts)

Posts: 7
Joined: 06/25/2008

Running Automate 9.0.5.4 on Windows 2k8 R2.

Any task with a "Focus Window" step, does not work as expected when the server is unattended. The task will run fine through the debugger. The task will also run correctly when manually run from task administrator. The task will run fine if someone has a remote desktop connection watching task administrator trigger the task on its own. When no one is logged in, and the task triggers, it will fail on the focus window step. I've attached my test code, which opens an IE browser, and attempt to focus it. It fails when it triggers on its own and there is no RDP session to the console.

 Category Survey
AutoMate 9 version: 9.0.5
Windows version: Windows Server 2008 R2



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)
 11/15/2016 03:13 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Mark,

Is the machine in a logged off or locked state when it fails?

Are you able to watch the logon or unlock sequence outside of RDP?

Make sure the logon settings are set to logon and unlock the machine.

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 11/16/2016 07:15 AM
User is offline View Users Profile Print this message

Author Icon
MarkLee
Student (5-19 posts)

Posts: 7
Joined: 06/25/2008

The logon settings are set.
When the workstation is logged on: Logged on User
When the workstation is logged off: Logon Specified User(defined below)
When the workstation is locked: Run as Current User

Specified User is set to use the 'Default User' account.
Default User is set. We know this because it does log on to the console as this default user.

 Category Survey
AutoMate 9 version: 9.0.5
Windows version: Windows Server 2008 R2
 11/16/2016 08:29 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Mark,

Make sure to change the setting for when the workstation is locked to unlock using specified user.

I would suggest that you setup scenarios where you watch AutoMate logon and unlock the machine, this way you can narrow down when it fails.

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 11/16/2016 08:33 AM
User is offline View Users Profile Print this message

Author Icon
MarkLee
Student (5-19 posts)

Posts: 7
Joined: 06/25/2008

But the point is that it won't fail when we're watching... Have you tried replicating the issue? Set up the task to run on a schedule and see if it fails?

 Category Survey
AutoMate 9 version: 9.0.5
Windows version: Windows Server 2008 R2
 11/16/2016 03:06 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Mark,

This issue usually occurs when the logon or unlock sequence does not work correctly.

Does your machine have sleep mode activated? If so would it be possible to disable it?

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 11/17/2016 08:16 AM
User is offline View Users Profile Print this message

Author Icon
MarkLee
Student (5-19 posts)

Posts: 7
Joined: 06/25/2008

The logon and unlock sequence works just fine. The task does trigger correctly. When we log on to the console, we can see the IE window up, it just fails on the step which focuses the window. The machines do not have sleep mode enabled.

 Category Survey
AutoMate 9 version: 9.0.5
Windows version: Windows Server 2008 R2
 11/17/2016 08:19 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Mark,

Do you have the option "Disable Foreground Window" checked off? Please make sure you have it checked in the following location;

Open AMTA --> Select Options --> Select System Settings --> Select Execution

Let us know your results.

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 11/17/2016 09:07 AM
User is offline View Users Profile Print this message

Author Icon
MarkLee
Student (5-19 posts)

Posts: 7
Joined: 06/25/2008

Yes, it is checked. Have you tried running the steps I attached in the original post to try to replicate the issue?

 Category Survey
AutoMate 9 version: 9.0.5
Windows version: Windows Server 2008 R2
 11/17/2016 11:01 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Mark,

I have and each time its run successfully.

How are you watching the logon/unlock scenario outside of RDP? Are you sitting in front of the physical machine or can you use LogMeIn or RealVNC?

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 11/17/2016 11:18 AM
User is offline View Users Profile Print this message

Author Icon
MarkLee
Student (5-19 posts)

Posts: 7
Joined: 06/25/2008

I'm not watching it. If it fails, it wouldn't run at all. I would not be able to see the IE windows left open by the automate task when I remote desktop in to the console, because the focus window step failed.

 Category Survey
AutoMate 9 version: 9.0.5
Windows version: Windows Server 2008 R2
 11/18/2016 09:14 AM
User is offline View Users Profile Print this message

Author Icon
Alex Escalante
HelpSystems

Posts: 871
Joined: 02/26/2014

Hello Mark,

At this point, since something is obviously not working during the logon/unlock process, and we will need to see what it is exactly. We recommend installing a trial version of RealVNC or TightVNC so that the window is left open when we log off, allowing us to see the process in its entirety.

Once the VNC viewer is ready, please open a support ticket (please reference this thread) and send your availability so that we may schedule a support session to resolve the issue.

Thanks!

 Category Survey


-------------------------

Alex Escalante | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 11/18/2016 09:16 AM
User is offline View Users Profile Print this message

Author Icon
Justin Aucoin
HelpSystems

Posts: 360
Joined: 02/15/2016

Hi Mark,

Are the RDP sessions being closed by logging off, or is the session just disconnected?

 Category Survey
AutoMate 9 version:
Windows version:


-------------------------

Justin Aucoin | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 931 guests browsing this forum, which makes a total of 931 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog