Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Calculating Used Disk Space
Topic Summary:
Created On: 01/24/2017 06:45 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/24/2017 06:45 AM
User is offline View Users Profile Print this message

Author Icon
WilhelmEvans
Journeyman (50-99)

Posts: 85
Joined: 10/30/2014

I'm tasked to alert people when a disk reaches 80% full.  So far I can only get this.: Variable A: Total Current Space 62017336  Variable B: Used space 462270660.   What options in Automate can i use to get these into  an email to produce what the Percentage of used space is?  Can you help me please?   I will eventually use an if statement to send an allert when the disk reaches 80%.   



 Category Survey
 01/24/2017 08:44 AM
User is offline View Users Profile Print this message

Author Icon
Devin Cannon
HelpSystems

Posts: 398
Joined: 03/17/2016

Hi Wilhelm,

Here is an example of how to do this.



 Category Survey



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)





-------------------------

Devin Cannon | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 01/24/2017 11:53 AM
User is offline View Users Profile Print this message

Author Icon
WilhelmEvans
Journeyman (50-99)

Posts: 85
Joined: 10/30/2014

Worked like a charm.  Thank you kindly



 Category Survey
 01/24/2017 12:27 PM
User is offline View Users Profile Print this message

Author Icon
WilhelmEvans
Journeyman (50-99)

Posts: 85
Joined: 10/30/2014

well,  it worked great until i set it to run in the background.  I'm using the same credentials and even mapped the network drive I need to monitor.  I can run the tasks without fail, but get this error when the task triggers: 

Error message: The specified volume does not exist on this machine. 

Any ideas?



 Category Survey
 01/25/2017 05:21 AM
User is offline View Users Profile Print this message

Author Icon
WilhelmEvans
Journeyman (50-99)

Posts: 85
Joined: 10/30/2014

I'm tried the administrator account we created for Automate with the highest privilages and I'm still unable to run the task on any schedule in the background, but I can run it manually and all is perfect.  I really would love a solution to this issue.   To give you more info,  we normally RDP to this server, but I have, or both I and Automate have Admin rights to the folders using the IP address which is mapped on both logons. 



 Category Survey
 01/26/2017 07:23 AM
User is offline View Users Profile Print this message

Author Icon
WilhelmEvans
Journeyman (50-99)

Posts: 85
Joined: 10/30/2014

I would love to share my screen if that would help trouble shoot the issue.



 Category Survey
 01/26/2017 09:53 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello,

Would it be possible to set-up a GoToAssist session where we can take a closer look at this issue? If this is possible please send an email over to AutoMate.Support@helpsystems.com with a list of your availability.

Note: Please reference this forum thread in your email.


 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1113 guests browsing this forum, which makes a total of 1113 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog