Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Stuck Shift Key?
Topic Summary:
Created On: 01/26/2017 06:02 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/26/2017 06:02 PM
User is offline View Users Profile Print this message

Author Icon
WilliamWatkins
Journeyman (50-99)

Posts: 100
Joined: 07/08/2014

I am using the Send keystrokes action to enter text into a field of a Citrix browser.  I cannot use any other action to enter the text.  It usually works.  However, recently I have been seeing the field set to "P#@)&^" instead of "p32076".  It is as though the shift key is being held while the keystrokes are being sent.  I tried the {CAPSOFF} to no avail.  The CAPSLOCK being on should not cause the number keys to be shifted.  Any thoughts?



 Category Survey
AutoMate 9 version: 9.0.5
Windows version: Windows 10
 01/27/2017 11:52 AM
User is offline View Users Profile Print this message

Author Icon
Devin Cannon
HelpSystems

Posts: 398
Joined: 03/17/2016

Hi William,

You can try adding a step before the send keystrokes step to release the shift key:

<AMINPUT ACTIVITY="release_key" SHIFT="YES" />



 Category Survey



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)


-------------------------

Devin Cannon | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 01/30/2017 10:43 AM
User is offline View Users Profile Print this message

Author Icon
WilliamWatkins
Journeyman (50-99)

Posts: 100
Joined: 07/08/2014

Thanks for the tip.  The action prior to the Send keystrokes action was a {Shift}F12 to save an Excel spreadsheet.  I don't know why the Shift key should be held down after that action.  I changed that to {Ctrl}s to save the spreadsheet instead.  Things are working as they should now.  Thanks again.



 Category Survey
AutoMate 9 version: 9.0.5
Windows version: Windows 10
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1509 guests browsing this forum, which makes a total of 1509 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog