Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Disable Windows Foreground timeout
Topic Summary:
Created On: 06/21/2017 10:14 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/21/2017 10:14 AM
User is offline View Users Profile Print this message

Author Icon
WilliamWatkins
Journeyman (50-99)

Posts: 100
Joined: 07/08/2014

On several occasions the "Disable Windows Foreground timeout" checkbox is unchecked when AM9 starts.  I notice the erratic behaviour in the Task and have to check the box.  Why does the setting change on its own?



 Category Survey
AutoMate 9 version: 9.0.5
Windows version: Windows 10
 06/21/2017 11:18 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

William,

It's not a static setting within Automate. If you actively select or unselect the option from Task Administrator and click OK, a call to Windows is made to adjust the timeout. This call only occurs when that setting is updated and the OK button is clicked. If you go back into that option, the selection or unselection of the box is based on Automate asking Windows what the current setting is. If the setting does not match what you had initially configured it as, then that means another application and/or policy is making the adjustment on a system reboot or startup of an application. One such application that updates this setting on a regular basis is Radmin.



 Category Survey
AutoMate 9 version:
Windows version:


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 01/10/2018 08:01 AM
User is offline View Users Profile Print this message

Author Icon
WilliamWatkins
Journeyman (50-99)

Posts: 100
Joined: 07/08/2014

Is there a way for me to have a task set this setting in Windows to the desired state?

 Category Survey
AutoMate 9 version: 9.0.5
Windows version: Windows 10
 01/10/2018 08:11 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Hi William,

You can try editing the following DWORD from the registry:

HKEY_CURRENT_USER\Control Panel\Desktop\

ForegroundLockTimeout

Enable Value - 200000 (decimal)
Disable Value - 0 (decimal)

 Category Survey
AutoMate 9 version:
Windows version:


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1831 guests browsing this forum, which makes a total of 1831 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog