Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: BPA Execution Server Errors: The given key was not present in the dictionary.
Topic Summary: Error/issue causes WF to stop processing and requires BPA ExSvr service restart
Created On: 07/22/2015 09:17 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
Answer This question was answered by AdamConner, on Tuesday, July 28, 2015 6:15 AM

Answer:

Thanks Alex. I'll see if I can identify a window to run the update and open a support ticket.

 07/22/2015 09:17 AM
User is offline View Users Profile Print this message

Author Icon
AdamConner
Journeyman (50-99)

Posts: 55
Joined: 02/20/2014

I've started to receive several BPA Execution Server errors that are causing WF's to stop processing (without error) and freeze in the Execution Status pane in the SMC. The Agent server does not show any active WF/Tasks when this occurs and the WF/Tasks in the Execution Status pane cannot be stopped/paused/cleared. The only way I've found to clear the Execution Status pane is to manually restart the BPA Execution Server service.

I noticed that over the past month this error has occurred around the same time in a workflow. I have just recently added additional logging to help pinpoint the specific Task/Step though so the error point is still unknown.

Appears that this error has come up in several versions of BPA. Any fixes available for BPA v9.0.4.5?

 

Initial Error Reported:

System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)

   at AutoMate.BPAServer.Execution.RunningWorkFlowInstance.?(String OriginalSerialization, String NewSerialization)

   at AutoMate.BPAServer.Execution.RunningWorkFlowInstance.?(String WorkflowItemInstanceID, AutomationObjectRunResult Result)

 

Error Reported When Execution Service Restarted After Issue Above:

System.NullReferenceException: Object reference not set to an instance of an object.

   at AutoMate.BPAServer.Execution.VariableEngineManager.?(String WorkflowInstanceID, VariableEngineMessageType MessageType, Object[] Parameters)

   at AutoMate.BPAServer.Execution.VariableEngineManager.GetNameValuePairs(String WorkflowInstanceID)

   at AutoMate.BPAServer.Execution.RunningWorkFlowInstance.?(String OriginalSerialization, String NewSerialization)

   at AutoMate.BPAServer.Execution.RunningWorkFlowInstance.?(String WorkflowItemInstanceID, AutomationObjectRunResult Result)

 



 Category Survey
AutoMate BPA Server 9 version: 9.0.5
Windows version: Windows Server 2008 R2
 07/27/2015 07:05 AM
User is offline View Users Profile Print this message

Author Icon
Alex Escalante
HelpSystems

Posts: 871
Joined: 02/26/2014

Hello Adam,

Our first step to solving this issue is to have you upgrade to the latest version 9054. Please open a support ticket and reference this forum thread. We will then be able to assist you with the upgrade process.

Thanks!

 Category Survey


-------------------------

Alex Escalante | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 07/28/2015 06:15 AM
User is offline View Users Profile Print this message

Author Icon
AdamConner
Journeyman (50-99)

Posts: 55
Joined: 02/20/2014

Answer Answer

Thanks Alex. I'll see if I can identify a window to run the update and open a support ticket.



 Category Survey
AutoMate BPA Server 9 version: 9.0.5
Windows version: Windows Server 2008 R2
 07/29/2015 11:28 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Adam,

We look forward to hear from you.

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 09/22/2015 06:39 AM
User is offline View Users Profile Print this message

Author Icon
AdamConner
Journeyman (50-99)

Posts: 55
Joined: 02/20/2014

Hi Ricardo, 

I upgraded BPA to v9.0.5.4 a few weeks ago and unfortunately the update did not resolve the "The given key was not present in the dictionary" error in WF reported above. I'll be opening a ticket to dig into this further with support.

Of course this happens to be our most critical workflow so the issue has been discouraging to say the least.

 



 Category Survey
AutoMate BPA Server 9 version: 9.0.5
Windows version: Windows Server 2008 R2
 09/23/2015 04:22 PM
User is offline View Users Profile Print this message

Author Icon
Valentineo McGowan
HelpSystems

Posts: 766
Joined: 09/03/2013

Hello Adam,

FYI I have sent you an interaction response on Support Ticket #56016c059cd92.

 Category Survey


-------------------------

Valentineo McGowan | Technical Consultant
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1 213.738.6966 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 733 guests browsing this forum, which makes a total of 733 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog