Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Oracle ODBC Connection
Topic Summary:
Created On: 05/18/2016 04:43 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/18/2016 04:43 AM
User is offline View Users Profile Print this message

Author Icon
MichaelUnterstab
n00b (>6 posts)

Posts: 4
Joined: 11/13/2013

Hi,

I am trying to open a connection to an Oracle 10g DB, but I always get an "initializing provider. Authentification failed" error.

I created a system DNS with the same credentials and the connection tests cuccessful. (Using Oracle 10g ODBC Driver)

No matter if I try to use this connection with OLE for ODBC Provider or another Oracle OLE DB Provider I can't connect. I usually get an TNS error that the name can't be resolved - even if I use the IP.

What am I doing wrong?

edit: another error message I receive is

Operation cannot be executed because an error occured during connection to the driver.

 

Edit2:

I successfully created an UDL-File using Oracle OLE Provider. But using it in OpenConnection-Task also fails.

This time its a TNS-error (ORA-12154)

Thanks in advance,

 

Michael



 Category Survey
AutoMate BPA Server 9 version: 9.0.4
Windows version: Windows Server 2008 R2


Edited: 05/18/2016 at 06:15 AM by MichaelUnterstab
 05/19/2016 12:54 PM
User is offline View Users Profile Print this message

Author Icon
Alex Escalante
HelpSystems

Posts: 871
Joined: 02/26/2014

Hello Michael,

BPA9 is a 32 bit application, so it will require a 32bit driver. Is the driver you are using 32 or 64bit?

When creating the connection, do you see the correct provider listed in the provider list?

 Category Survey


-------------------------

Alex Escalante | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 05/23/2016 05:11 AM
User is offline View Users Profile Print this message

Author Icon
MichaelUnterstab
n00b (>6 posts)

Posts: 4
Joined: 11/13/2013

Thank you for your reply.

 

Yes, the driver ist 32bit.

 

Well, I tried these providers from the list:

Microsoft OLE DB Providers for ODBC drivers

Microsoft OLE DB Providers for Oracle

Oracle Provider for OLE DB

Thats the connection string from the UDL-File (\w uid, pwd and source name):

Provider=OraOLEDB.Oracle.1;Password=***;Persist Security Info=True;User ID=***;Data Source=***

And as I wrote in the opening post, there's also a ODBC-Connection I can select but won't connect (connection tested successful on creation)

Michael

 

PS: Maybe I found the problem. There seems to be an issue when the application using the Oracle driver is installed in a directory containing brackets (like c:\program files (x86)). Unfortunatly I would have to reinstall BPA Server to confirm the problem.

Confirmed my theory by creating a symbolic link without brackets.



 Category Survey
AutoMate BPA Server 9 version: 9.0.4
Windows version: Windows Server 2008 R2


Edited: 05/23/2016 at 06:56 AM by MichaelUnterstab
 05/23/2016 03:43 PM
User is offline View Users Profile Print this message

Author Icon
Devin Cannon
HelpSystems

Posts: 398
Joined: 03/17/2016

Hi Michael,

Are you able to successfully connect to the Orable DB now?



 Category Survey
AutoMate BPA Server 9 version:
Windows version:


-------------------------

Devin Cannon | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 05/24/2016 02:32 AM
User is offline View Users Profile Print this message

Author Icon
MichaelUnterstab
n00b (>6 posts)

Posts: 4
Joined: 11/13/2013

Originally posted by: DevinCannon Hi Michael,

 

Are you able to successfully connect to the Orable DB now?

 

 

Yes, the connection test was successful.

 

- Michael



 Category Survey
AutoMate BPA Server 9 version: 9.0.4
Windows version: Windows Server 2008 R2
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 2113 guests browsing this forum, which makes a total of 2113 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog