Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Decompress fails
Topic Summary:
Created On: 08/03/2016 09:37 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/03/2016 09:37 AM
User is offline View Users Profile Print this message

Author Icon
KumarParameswaran
Expert (100-199)

Posts: 127
Joined: 10/10/2012

When I try to decompress a zip file (.7z), I am getting file files decompressed error. The file that needs to be decomoressed exists in that location.

 



 Category Survey
AutoMate BPA Server 9 version: 9.0.3
Windows version: Windows Server 2008 R2



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)
 08/03/2016 10:08 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hi Kumar,

Can post a screenshot of the exact error that you are running into?

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 08/03/2016 11:48 AM
User is offline View Users Profile Print this message

Author Icon
KumarParameswaran
Expert (100-199)

Posts: 127
Joined: 10/10/2012

Hi Ricardo,

Please let me know if you need more information.

Thanks



 Category Survey
AutoMate BPA Server 9 version: 9.0.3
Windows version: Windows Server 2008 R2


Click for full image
Click for larger image

 08/03/2016 02:56 PM
User is offline View Users Profile Print this message

Author Icon
Justin Aucoin
HelpSystems

Posts: 360
Joined: 02/15/2016

Hi Kumar,

We were able to reproduce this issue testing with AutoMate 9.0.5.4, which was the final release of AutoMate 9. However in testing with the current version of AutoMate 10, the files are able to be successfully extracted. So we would recommend upgrading to the current release of AutoMate 10 to resolve this issue. As AutoMate 9 and AutoMate 10 use different ports, you can run them side by side if you chose to upgrade and transition the tasks over time.

 Category Survey
AutoMate BPA Server 9 version:
Windows version:


-------------------------

Justin Aucoin | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 08/04/2016 08:21 AM
User is offline View Users Profile Print this message

Author Icon
KumarParameswaran
Expert (100-199)

Posts: 127
Joined: 10/10/2012

Thanks Justin.

The decompress was just working fine earlier without any issue. Not sure which MS Patch messed this up.

Thank you



 Category Survey
AutoMate BPA Server 9 version: 9.0.3
Windows version: Windows Server 2008 R2
 08/04/2016 02:16 PM
User is offline View Users Profile Print this message

Author Icon
Justin Aucoin
HelpSystems

Posts: 360
Joined: 02/15/2016

Hi Kumar,

What is the compression method for the file? If the file was created using a different deflate method, as opposed 7 Zip's LZMA method, this can lead to this error message.

 Category Survey
AutoMate BPA Server 9 version:
Windows version:


-------------------------

Justin Aucoin | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 08/18/2016 09:12 AM
User is offline View Users Profile Print this message

Author Icon
KumarParameswaran
Expert (100-199)

Posts: 127
Joined: 10/10/2012

Hi Justin,

The vendor says the haven't changed the compression method.

Thank you



 Category Survey
AutoMate BPA Server 9 version: 9.0.3
Windows version: Windows Server 2008 R2
 08/19/2016 08:41 AM
User is offline View Users Profile Print this message

Author Icon
Justin Aucoin
HelpSystems

Posts: 360
Joined: 02/15/2016

Hi Kumar,

Is this occurring with all 7zip files from this vendor now, or just one in particular?
Also are you able to decompress the the 7zip file outside of BPA?

 Category Survey
AutoMate BPA Server 9 version:
Windows version:


-------------------------

Justin Aucoin | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 08/23/2016 10:13 AM
User is offline View Users Profile Print this message

Author Icon
KumarParameswaran
Expert (100-199)

Posts: 127
Joined: 10/10/2012

Hi Justin,

Yes this is occuring with a .7zip file from this vendor. And I couldn't extract .zip file as well.

Yes, I am able to extract the .7zip file outside of BPA.

Thank you



 Category Survey
AutoMate BPA Server 9 version: 9.0.3
Windows version: Windows Server 2008 R2
 08/24/2016 01:05 PM
User is offline View Users Profile Print this message

Author Icon
Justin Aucoin
HelpSystems

Posts: 360
Joined: 02/15/2016

Hi Kumar,

I was able to reproduce this issue in v9.5.4 by using a compressed 7 zip compressed with the deflate method, as opposed 7 Zip's LZMA method. Using the same file and steps, I was able to successfully decompress the file using AutoMate 10.4.2.1. My recommendation would be upgrade your AutoMate to version 10 to resolve this issue going forward.

 Category Survey
AutoMate BPA Server 9 version:
Windows version:


-------------------------

Justin Aucoin | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 2358 guests browsing this forum, which makes a total of 2358 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog