Network Automation Software
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: I want to delete all files and folders from a share that are older than a year
Topic Summary:
Created On: 03/08/2018 03:02 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/08/2018 03:02 PM
User is offline View Users Profile Print this message

Author Icon
JohnReckas
Student (5-19 posts)

Posts: 9
Joined: 01/18/2018

It seems simple but when I use the filesystem activity delete and choose folder and choose include subfolders, I created a test folder with test files I chose newer than like 5 minutes before I created the file and the task just sits there. I let it run for 30 minutes and it still hadn't finished and there are only 4 1kb files across 2 subfolders.

The real job is I want to check all of \\wnp-maq-pfs1\Archived Data\
and delete and files and folders that are older than 12 months.

 Category Survey
AutoMate BPA Server 9 version: 9.0.5
Windows version: Windows Server 2008 R2



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)
 03/09/2018 11:19 AM
User is offline View Users Profile Print this message

Author Icon
KennethLewis
Student (5-19 posts)

Posts: 7
Joined: 03/31/2016

I have a task does deletes files older than 30 days. The difference I see in yours that may be a problem is that the ISNEWERTHAN should be ISOLDERTHAN.

 Category Survey
 03/09/2018 11:32 AM
User is offline View Users Profile Print this message

Author Icon
JohnReckas
Student (5-19 posts)

Posts: 9
Joined: 01/18/2018

The only reason I have ISNEWERTHAN is because I created a test folder and files to delete. If I do an ISOLDERTHAN on the real directories and choose files,it will delete files but then it just leaves empty folders.

 Category Survey
AutoMate BPA Server 9 version: 9.0.5
Windows version: Windows Server 2008 R2
 03/14/2018 06:36 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Hi John,

Please try your step again as outlined below.

 Category Survey
AutoMate BPA Server 9 version:
Windows version:



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 03/28/2018 02:04 PM
User is offline View Users Profile Print this message

Author Icon
JohnReckas
Student (5-19 posts)

Posts: 9
Joined: 01/18/2018

Getting error

[Main](Step 0) Task Started.
[Main](Step 1) Starting activity "File System: Delete"...
[Main](Step 1) No folder(s) found.
[Main](Step 1) Task Ended.


This is the folder structure
\\wnp-maq-pfs1\Archived Data\Delete script test folder
Subfolders:
test1
test2

 Category Survey
AutoMate BPA Server 9 version: 9.0.5
Windows version: Windows Server 2008 R2
 04/02/2018 09:00 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello,

Can you confirm that there is a folder named Delete script test folder in that location?

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 04/27/2018 02:54 PM
User is offline View Users Profile Print this message

Author Icon
JohnReckas
Student (5-19 posts)

Posts: 9
Joined: 01/18/2018

Originally posted by: Ricardo Castaneda

Hello,



Can you confirm that there is a folder named Delete script test folder in that location?


See attached.

 Category Survey
AutoMate BPA Server 9 version: 9.0.5
Windows version: Windows Server 2008 R2


Click for full image
Click for larger image

Statistics
18257 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 6686 on 11/01/2020 at 01:24 AM.
There are currently 395 guests browsing this forum, which makes a total of 395 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2021 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog