Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Why no global variables in BPA Server?
Topic Summary:
Created On: 02/03/2014 02:26 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/03/2014 02:26 AM
User is offline View Users Profile Print this message

Author Icon
JamesHalinson
Expert (100-199)

Posts: 122
Joined: 12/11/2013

Hi,

I was wondering if there is a techincal reason why Automate BPA Server doesn't have global variables, only global constants? We are trialing it and a couple of other products both of which have global variables.
We have had to implement similar in BPA Server by writing the variables to a database table.

Thanks,

James

 02/03/2014 08:46 AM
User is offline View Users Profile Print this message

Author Icon
Valentineo McGowan
HelpSystems

Posts: 766
Joined: 09/03/2013

Hello James,

Within Workflow Designer along the bottom tabs you can create and utilize 'shared variables' as well as shared arrays for an entire Workflow and all tasks contained within that workflow.
Have you used this feature yet?

-------------------------

Valentineo McGowan | Technical Consultant
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1 213.738.6966 | F: +1.213.738.7665
 02/03/2014 08:54 AM
User is offline View Users Profile Print this message

Author Icon
JamesHalinson
Expert (100-199)

Posts: 122
Joined: 12/11/2013

Hi Valentino,

No I haven't tried this yet but will look into it.

Would be good if they could be shared across workflows though.

Thanks,

James

Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1361 guests browsing this forum, which makes a total of 1361 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog