Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: retreiving emails from gmail
Topic Summary:
Created On: 08/18/2015 12:18 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/18/2015 12:18 AM
User is offline View Users Profile Print this message

Author Icon
HaHa
Apprentice (20-49)

Posts: 26
Joined: 08/02/2015

hello

i would like to check my email and retreive messages from gmail, but the configuration is not working, what is the right configuration for gmail? and how can i open the links in the email to get the contents copied



 Category Survey
AutoMate 10 version: 10.0.0
Windows version: Windows 10
 08/18/2015 06:57 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Please see the following link to configure your email settings properly:

https://support.google.com/mail/troubleshooter/1668960



 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 08/19/2015 01:26 AM
User is offline View Users Profile Print this message

Author Icon
HaHa
Apprentice (20-49)

Posts: 26
Joined: 08/02/2015

i tried it but it's still giving an error!

maybe i'm doing it wrong, what i want is to get the emails which contains some links, and get the contents of the web pages of these links.

what is the best practice?



 Category Survey
AutoMate 10 version: 10.0.0
Windows version: Windows 10
 08/19/2015 07:03 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Are you able to retrieve your email without any filtering? We need to make sure that retrieving emails works properly first.




 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 08/20/2015 12:16 AM
User is offline View Users Profile Print this message

Author Icon
HaHa
Apprentice (20-49)

Posts: 26
Joined: 08/02/2015

no it's not working, it's something related to the connection or security, it returns that the server has closed the connection



 Category Survey
AutoMate 10 version: 10.0.0
Windows version: Windows 10
 08/20/2015 02:07 AM
User is offline View Users Profile Print this message

Author Icon
HaHa
Apprentice (20-49)

Posts: 26
Joined: 08/02/2015

i also tried recommendations from google, like lowering the security for some mail clients



 Category Survey
AutoMate 10 version: 10.0.0
Windows version: Windows 10
 08/20/2015 01:27 PM
User is offline View Users Profile Print this message

Author Icon
Alex Escalante
HelpSystems

Posts: 871
Joined: 02/26/2014

Hello Ha,

Are you able to send emails successfully using Gmail through AutoMate?

What version of AutoMate 10 are you running (10.0, 10.1, 10.2 or 10.3)?

 Category Survey


-------------------------

Alex Escalante | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 08/21/2015 11:21 AM
User is offline View Users Profile Print this message

Author Icon
HaHa
Apprentice (20-49)

Posts: 26
Joined: 08/02/2015

no i'm not able to send emails

it's 10.0



 Category Survey
AutoMate 10 version: 10.0.0
Windows version: Windows 10
 08/22/2015 12:13 AM
User is offline View Users Profile Print this message

Author Icon
HaHa
Apprentice (20-49)

Posts: 26
Joined: 08/02/2015

i changed the email, i'm using another one on another server (not gmail)

but i need some help in the tasks, i need it to grab the email, then open the links inside of it.



 Category Survey
AutoMate 10 version: 10.0.0
Windows version: Windows 10
 08/24/2015 12:02 PM
User is offline View Users Profile Print this message

Author Icon
Alex Escalante
HelpSystems

Posts: 871
Joined: 02/26/2014

Hello,

Are you able to successfully receive email?

Is it possible to post your task or task steps for review?

 Category Survey


-------------------------

Alex Escalante | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 08/25/2015 07:42 AM
User is offline View Users Profile Print this message

Author Icon
HaHa
Apprentice (20-49)

Posts: 26
Joined: 08/02/2015

yes i changed to another domain service and i'm using the "get email" task only, i'm new to this, so where does these emails go, i set it to create and populate dataset, is that right?



 Category Survey
AutoMate 10 version: 10.0.0
Windows version: Windows 10
 08/25/2015 11:50 AM
User is offline View Users Profile Print this message

Author Icon
Alex Escalante
HelpSystems

Posts: 871
Joined: 02/26/2014

Hello,

Yes, you will populate a dataset, which gives you all the info regarding the message(s). You can then use the dataset parameters to use the information contained within the email.

Below you will find the steps of the example "check email for different subjects". As you can see, a dataset is populated, then the dataset parameter is used to show the subject line within a dialog box.

Please let us know if you have any questions or concerns.

 Category Survey



Task Steps: (Right click, Select All, Copy to copy to the clipboard. Steps can then be pasted into the AutoMate Task Builder)


-------------------------

Alex Escalante | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 08/25/2015 10:38 PM
User is offline View Users Profile Print this message

Author Icon
HaHa
Apprentice (20-49)

Posts: 26
Joined: 08/02/2015

inside the body of the messages there's some urls so how can i open them after i've got the emails?

the idea is:

get mail

open urls inside of it (url of articles)

copy these articles

paste it on a certain website that summarize it

copy the summarization

send it back by email to me

can you help me with that



 Category Survey
AutoMate 10 version: 10.0.0
Windows version: Windows 10
 08/28/2015 11:27 AM
User is offline View Users Profile Print this message

Author Icon
Mary Manzano
HelpSystems

Posts: 280
Joined: 03/10/2014

Hello,

 

Once you have the body of the email in a dataset you can write that to a text file and manipulate the data using Text actions to grab the url. Populate a variable with the URL and you can then open a Web Browser to open a webpage using the variable to populate the URL address field.

Here are some helpfull links on how to use the text actions.
http://www.networkautomation.com/urc/search/?searchFor=st&searchTerm=Text 



 Category Survey
AutoMate 10 version:
Windows version:


-------------------------
Mary Manzano | Technical Consultant
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 10/28/2017 05:01 AM
User is offline View Users Profile Print this message

Author Icon
AsinKi
n00b (>6 posts)

Posts: 1
Joined: 10/28/2017

Also can`t recieve messages.

Email failed (Error : The server has closed the connection.)

Options are the same as in my other email clients

 



 Category Survey
AutoMate 10 version:
Windows version: Windows 8.1
 10/30/2017 03:53 PM
User is offline View Users Profile Print this message

Author Icon
Devin Cannon
HelpSystems

Posts: 398
Joined: 03/17/2016

Hi,

Choose "Implicit TLS/SSL" instead of "Explicit".  IMAP needs to be enabled for the gmail account as well.  To enable IMAP please check out Step 1 here:

https://support.google.com/mail/answer/7126229?hl=en



 Category Survey


-------------------------

Devin Cannon | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1835 guests browsing this forum, which makes a total of 1835 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog