Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Database Trigger on UPDATE
Topic Summary:
Created On: 02/02/2018 12:15 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/02/2018 12:15 PM
User is offline View Users Profile Print this message

Author Icon
HarleyEllenberger
Student (5-19 posts)

Posts: 18
Joined: 09/09/2005

I'm having trouble getting a task to trigger based on a database update event.

I have trigger set to start my task after a table in a remote Oracle database is updated. The table is a single record with a date/time stamp. That date/time stamp gets updated at a different time every Sunday morning. I want my task to trigger after that date/time stamp is updated. The table is updated via an "UPDATE <tablename> SET <columnname> = SYSDATE" statement that is passed on the host machine.

I've set up the required connection strings to the database and I can execute SQL queries against this table in a task, but I can't get the task to trigger.

Any ideas on where to look?

 Category Survey
AutoMate 10 version: 10.3.0
Windows version: Windows Server 2008 R2
 02/05/2018 02:14 PM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello,

I would suggest that you update the trigger then check the "Windows Event Viewer" under application, there will be a message letting you know if a successful connection has been made.

Please let us know your result.

 Category Survey


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 465 guests browsing this forum, which makes a total of 465 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog