Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: Apllication event error after new installation and migration
Topic Summary: We get the following error in the server event log
Created On: 05/18/2017 02:33 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/18/2017 02:33 AM
User is offline View Users Profile Print this message

Author Icon
JoakimAndersson
Student (5-19 posts)

Posts: 17
Joined: 01/20/2014

This error occurs multiple times in the event log. 
What is the cause and is there a fix.

We are using version 10.7.0.3

System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

 

at System.Collections.Generic.Dictionary`2.get_Item(TKey key)

 

at AutoMate.BPAServer.Execution.TaskManager.UpdateTaskInstance(String AgentID, String InstanceID, DateTime LastChanged, String CurrentFunctionName, Int32 CurrentStepNumber, String CurrentStepDescription)

 

at AutoMate.BPAServer.Execution.ExecutionServer.NotifyOfStepLoggingEventRequest(NotifyOfStepLoggingEventRequestMessage Request, BPAExecutionServerSession theSession)

 



 Category Survey
AutoMate BPA Server 10 version: 10.7.0
Windows version: Windows Server 2008 R2
 05/22/2017 07:47 AM
User is offline View Users Profile Print this message

Author Icon
Justin Aucoin
HelpSystems

Posts: 360
Joined: 02/15/2016

Hi JoakimAndersson,

We will work on this issue with your colleague via our Support Portal and update this forum thread with the resolution.

 Category Survey
AutoMate BPA Server 10 version:
Windows version:


-------------------------

Justin Aucoin | Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700 | F: +1.213.738.7665
 06/15/2017 07:44 AM
User is offline View Users Profile Print this message

Author Icon
AdamConner
Journeyman (50-99)

Posts: 55
Joined: 02/20/2014

I have a ticket open for a similar error. Have been able to reproduce the issue by running a WF on an agent that doesn't have any default credentials setup.

After running the WF we first get an error reported by the Management Server that shows 10 exceptions similar to this:

=====================================================================
Exception #0:

System.Data.SqlClient.SqlException (0x80131904): Violation of PRIMARY KEY constraint 'PK__notifica__3214EC274959E263'. Cannot insert duplicate key in object 'dbo.notifications'.

The statement has been terminated.
=====================================================================

 

About a minute after this error is thrown we get an error similar to the one you described above that is reported by the BPA Execution Server.

 

=====================================================================
System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)

   at AutoMate.BPAServer.Execution.TaskManager.TaskCompleted(String InstanceID, RunTaskResult_t Result, String ErrorText, VariableListDataConstruct VariableData)

   at AutoMate.BPAServer.Execution.ExecutionServer.NotifyOfTaskRunCompletedRequest(NotifyOfTaskRunCompletedRequestMessage Request, BPAExecutionServerSession theSession)
=====================================================================

At that point in time the WF becomes stuck in the Execution Status Panel but isn't actually running on the server. At that point, we are only able to clear the WF from the Exceution Status Panel by restarting the Execution Server service.

 



 Category Survey
AutoMate BPA Server 10 version: 10.7.0
Windows version: Windows Server 2012 R2
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 1031 guests browsing this forum, which makes a total of 1031 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog