Network Automation Software We are currently migrating this forum
over to our HelpSystems domain. Please
post all new threads in our new
HelpSystems Community Portal.
Post to the HelpSystems Forum
You are not currently logged on. You must be logged on in order to post. Log on
Or Create a new account
AutoMate Discussion
Decrease font size
Increase font size
Topic Title: BPA Agent get disconnect while running SQL query.
Topic Summary: BPA Agent get disconnect while running SQL query.
Created On: 04/02/2018 11:15 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/02/2018 11:15 PM
User is offline View Users Profile Print this message

Author Icon
SonyMathew
Student (5-19 posts)

Posts: 12
Joined: 04/24/2016

Hi,


I am running a task which is inserting data from CSV to our database.

While running this task the agent get disconnected and AutoMate BPA Server 10 Agent service status go to stopped status, In event viewer i am getting below error.

EVENT VIEWER ERROR 1

Application: BPA_TS.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ArgumentOutOfRangeException
Stack:
at System.String.InternalSubStringWithChecks(Int32, Int32, Boolean)
at System.String.Substring(Int32, Int32)
at AutoMate.Communications.Client.GlobalStepLogReader.ProcessLine(System.String)
at AutoMate.Communications.Client.GlobalStepLogReader.DoWork()
at System.Threading.ThreadHelper.ThreadStart_Context(System.Object)
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
at System.Threading.ThreadHelper.ThreadStart()


EVENT VIEWER ERROR 2


Faulting application name: BPA_TS.exe, version: 10.5.0.56, time stamp: 0x00000000
Faulting module name: KERNELBASE.dll, version: 6.1.7601.23677, time stamp: 0x589c9620
Exception code: 0xe0434352
Fault offset: 0x0000c54f
Faulting process id: 0x228c
Faulting application start time: 0x01d3cb10a84ef059
Faulting application path: C:\Program Files (x86)\AutoMate BPA Server 10\BPA_TS.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: f20a4b10-3703-11e8-8312-a0481c8e2893

 Category Survey
AutoMate BPA Server 10 version: 10.5.0
Windows version: Windows Server 2008 R2


-------------------------




Regards,
Sony Mathew
 04/03/2018 06:44 AM
User is offline View Users Profile Print this message

Author Icon
Leonard Amabile
HelpSystems

Posts: 5454
Joined: 05/15/2007

Hi Sony,

I want to verify that this is occurring with every execution of the task or was this a one time occurrence?

 Category Survey


-------------------------

Leonard Amabile | Director, Cross Platform Support
AutoMate | InterMapper | Skybot | Divisions of HelpSystems
T: +1.213.738.1700 | F: +1.213.738.7665
 04/04/2018 04:08 AM
User is offline View Users Profile Print this message

Author Icon
SonyMathew
Student (5-19 posts)

Posts: 12
Joined: 04/24/2016

This is occurring with every execution of the task

 Category Survey
AutoMate BPA Server 10 version: 10.5.0
Windows version: Windows Server 2008 R2


-------------------------




Regards,
Sony Mathew
 04/04/2018 09:04 AM
User is offline View Users Profile Print this message

Author Icon
Ricardo Castaneda
HelpSystems

Posts: 3424
Joined: 01/11/2008

Hello,

Please email in and we will provide you a patch that correct this issue.

Note; Make sure to reference this forum thread in your email.

 Category Survey
AutoMate BPA Server 10 version:
Windows version:


-------------------------

Ricardo Castaneda | Principal Support Analyst
AutoMate | Division of HelpSystems
HelpSystems, LLC | T: +1.213.738.1700
 04/08/2018 03:05 AM
User is offline View Users Profile Print this message

Author Icon
SonyMathew
Student (5-19 posts)

Posts: 12
Joined: 04/24/2016

Hi,

I have send an email with the forum thread.

 Category Survey
AutoMate BPA Server 10 version: 10.5.0
Windows version: Windows Server 2008 R2


-------------------------




Regards,
Sony Mathew
Statistics
18258 users are registered to the AutoMate Discussion forum.
There are currently 0 users logged in.
The most users ever online was 5551 on 01/08/2018 at 11:11 AM.
There are currently 506 guests browsing this forum, which makes a total of 506 users using this forum.

FuseTalk Enterprise Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.

Sitemap Network Automation Software Blog